iPhone 3gs wont read sim card? what do i do...

Discussion in 'iPhone' started by jimbo23, Apr 23, 2012.

  1. jimbo23, Apr 23, 2012
    Last edited: Apr 23, 2012

    jimbo23 macrumors member

    Nov 2, 2009
    hey guys. a few months ago my gf got a iphone 3gs and got it unlocked from one of her friends, he said you cant upgrade the iphone or it will remove the unlock... well she updated it and sure enough the unlock is gone. its a iphone 3gs 5.1 and i tried jailbreaking it and installing ultrasn0w.. but the iphone still doesnt read the sim card. it either says "searching..." in the top left corner or "No Service."

    what do i do?

    thanks a bunch guys. really appreciate it!

    edit: i read of people using soldering guns n fixing it but i really dont have the tools or experience to do that. i need some ideas on how to fix it via software / computer.

    thanks again
  2. jimbo23 thread starter macrumors member

    Nov 2, 2009
  3. dontwalkhand macrumors 601


    Jul 5, 2007
    Phoenix, AZ
    This is EXACTLY what happened to me and my girlfriend's iPhone What a weird coincidence, that it also happens to be a 3GS ;)

    And since it worked for me, try your luck with Apple, you may just get lucky and get a new one :). No need for soldering guns, just rejailbreak with Redsn0w, and you should be good to go. Remember that it isn't really possible to brick an iPhone with this anymore. You'll be fine if you have had previous jail breaking experience before.
  4. jimbo23 thread starter macrumors member

    Nov 2, 2009
    Wow thanks man. ill check your thread out now.:D

Share This Page