iPhone 4.0 No cellular data

Discussion in 'iPhone Tips, Help and Troubleshooting' started by AnDi86, Apr 9, 2010.

  1. AnDi86 macrumors 6502

    Joined:
    Jan 15, 2007
    Location:
    Ballymoney N.Ireland
    #1
    I can't connect to the internet with 4.0 on my iPhone, have tried resetting all the settings restored 4.0 on it but no luck!

    I get a server has stop responding error when I try to load up anything on safari, anyone else having this problem?
     
  2. upaymeifixit macrumors 6502a

    upaymeifixit

    Joined:
    Feb 13, 2009
    #2
    The server not responding problem is most likely caused by the fact that you don't have an internet connection. Will it work on WiFi? The problem sounds like it may be an activation problem. I know it's an obvious question, but have you tried restoring it? If you sign my UDID I can tell you if I get the same error. :D
     
  3. redgaz26 macrumors 68020

    redgaz26

    Joined:
    Mar 6, 2007
    Location:
    Glasgow
  4. mg6101 macrumors newbie

    Joined:
    Sep 9, 2009
    #4
    Fix

    I ran into the same problem. Here is why that is happening. You followed musclenerd's redsn0w and jailbroke your 4.0 iphone 3g and then wanted to edit the N82AP.plist to allow multitasking and or home screen wallpaper. You installed openssh so you could ssh into your phone using cyberduck or any program like that. openssh is what onsets the issue. When you install openssh somehow it screws with all data connections (gprs,edge,3g,wifi) and you get the server not responding message. The root of the problem however is not openssh. It just came to my knowledge as I typed this reply that the problem is with redsn0w 0.9.5. and as of late Friday April 16 they released 0.9.5b2 which fixes that issue. I am going to try that and I hope it works. Updates momentarily as I try it...

    0.9.5b2 works for 3g cellular data, but at least for me wifi is still not working. I think that data of any sort is far better than no data whatsoever so if you havent reverted to 3.1.3 and you need openssh on 4.0 then this is your best bet.
     

Share This Page