iPhone 4.1 Update without Baseband Update

Discussion in 'Jailbreaks and iOS Hacks' started by Berges, Oct 15, 2010.

  1. Berges macrumors newbie

    Joined:
    Aug 12, 2010
    #1
    Ok, so I have read the forums and the TinyUmbrella ReadMe but just to be on the safe side of caution, I'd like to check if what I am about to do is right?

    I have an iPhone 4 and I'd like to update it to 4.1 without a baseband update. Since I need the Ultrasn0w unlock.

    These are the steps to be followed? Please advise me if I am going wrong anywhere, ALSO is it CERTAIN the TinyUmbrella will NOT update your baseband? Or is it a hit and miss deal?

    Start TinyUmbrella v4.1.6
    Start TSS Server
    Run iTunes and do a restore by pressing shift and using a stock 4.1 firmware file
    Let iTunes do its thing till I am thrown an error 1004
    Close iTunes and click on the Kick Device out of recovery


    This will CERTAINLY not upgrade my baseband Yes? ? ?

    Thanks :)
     
  2. solius macrumors regular

    Joined:
    Jul 15, 2010
    Location:
    Decatur AL
    #2
    I just did it worked just fine. I am now on 4.1 with my old baseband :) went very smoothly.
     
  3. kre62 macrumors 68000

    Joined:
    Jul 12, 2010
    #3
    If you want to be absolutely sure, just disconnect your internet after iTunes receives the initial authorization to proceed with the restore.

    At the very beginning, itunes "verifies the restore" with apple servers. After that, disconnect your internet. When itunes tries to get a sig on your baseband, it'll fail and end with the error. You will still need TU to kick the phone out of recovery, but you can guarantee you wont update your baseband this way.

    And yes, Sidewinder, I even found a way to manually preserve the baseband. Of course at this point you still need TU at the end, but if theres a way to kick out of recovery w/o it, ill find it.
     
  4. Berges thread starter macrumors newbie

    Joined:
    Aug 12, 2010
    #4
    Hey Kre,

    so iTunes tries to verify the baseband update mid way in and not at the end is it?
    Great.
     
  5. kre62 macrumors 68000

    Joined:
    Jul 12, 2010
    #5
    Yeah, the last thing it does is update the baseband. If there is no internet, it'll kick you out with the error. The phone will have 4.1 on it, but will be in recovery mode.

    I'm assuming all TU does is point the update server to a non existent location, effectively doing exactly what Im describing. But since many people have problems getting TU to work, I'd say be safe and go manual. I didnt even have TU when I did this the first time, I had to get it to kick the phone out of recovery though.

    Never said it was mid way..it is at the end.
     
  6. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #6
    To use Tinyumbrella TSS Server, you need to have already saved SHSH files on your computer.

    Run Tinyumbrella:
    1) Make sure you Iphone is detected.
    2) check "Advanced Options."
    3) In new window, under "Device / Version," select 4.1 firmware.
    4) Click on "Save my SHSH." If you don't get an error, it has been saved onto your computer.
    5) Repeat to save other firmware hashes if you wish.
    6) Now, click on "Display SHSHs." Make sure 4.1 is listed.
    7) Start "TSS server" and restore through iTunes with 4.1 firmware.
    8) Your phone should get stuck due to baseband not updating. Just use "Kick out of recovery..."'in Tinyumbrella.
    9) Your phone should now be on 4.1 firmware and 1.59 Baseband. Use whatever method you like to JB and Ultrasnow to unlock.
     
  7. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #7
    Interestingly enough, Tiny Umbrella 4.1.6 would not kick my iPhone 4 out of recovery mode. So, I downloaded Tiny Umbrella 4.1.4 and it had no problem kicking my iPhone 4 out of recovery mode.

    My iPhone 4 is now running iOS 4.1 with the 01.59 baseband.

    S-
     
  8. Sepp macrumors member

    Joined:
    Aug 7, 2010
    #8
    I was depending on unlock too - worked great for me, besides the fact, that Tiny Umbrella wouldn't kick my iPhone out of recovery - I googled, and found a little application which does both kick in and kick out the device of recovery.

    jailbreak did what it was supposed to do - Phone is running as it should...good luck
     
  9. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #9
    Uh, all you have to do is close TU (4.1.6) relaunch it and click the kick button again. I've done this about a dozen times now without issue.
     
  10. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #10
    Onnly because that's not really intuitive. At least all are successful and thanks for the tip!
     
  11. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #11
    It seemed like logical and simple troubleshooting to me. Don't be so quick to give up and search for other solutions when they are already right there in front of you.
     
  12. atlh3adl1n3r macrumors member

    Joined:
    Feb 16, 2010
    #12
    Is it best to setup your phone as new after upgrading or can you go ahead and do a restore from backup in iTunes?
     
  13. iPhone-power macrumors 6502a

    Joined:
    Nov 12, 2009
    #13
    TU 4.1.6 wouldn't work for me either, I also had to use 4.1.4 which worked as it was designed.
     
  14. yosi199 macrumors member

    Joined:
    Apr 12, 2010
    #14
    Will I need the at&t microsim for activation again after the upgrade to 4.1? I dont have it in hand and would not want to do this if It means I have a locked phone until I'll get an at&t card.
     
  15. Diode macrumors 68020

    Diode

    Joined:
    Apr 15, 2004
    Location:
    Washington DC
    #15
    Yes you will need a at&t sim at the current moment.
     
  16. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #16
    Uh....no! I quit and relaunched Tiny Umbrella at least 3 times before I resorted to other measures.....

    Thanks for playing though! ;)

    S-
     
  17. ali9686 macrumors member

    ali9686

    Joined:
    Jun 21, 2010
    #17
    that is what i did.. :D
     
  18. Berges thread starter macrumors newbie

    Joined:
    Aug 12, 2010
    #18
    Ok, so I updated to 4.1 without the baseband getting updated. As mentioned earlier, yes switch off the internet. And it works. As for getting the device out of Recovery mode, I had to kick it a couple of times, restart TU etc. But it finally happened.

    No issues otherwise. I am now using Limera1n, any prefer GreenPois0n over it?

    Unlock works just fine.

    My signal is consistently at 3 bars at home. Used to be a full 5 earlier. Donno if its a bug or its just a better description of the actual signal in the area? But my Nokia's, 2 of them both show full signal.

    Bluetooth etc work perfectly now.
     
  19. Berges thread starter macrumors newbie

    Joined:
    Aug 12, 2010
    #19
    Oh btw, FaceTime doesnt seem to work for some reason? It just doesnt stay on. If I choose On, it mentions waiting for activation and then goes back off, again.
    Any clue why?
     
  20. ZCherub macrumors 6502a

    ZCherub

    Joined:
    Jul 7, 2010
    Location:
    GA, USA
    #20
    I would like an answer to this as well! I preserved my 1.59 BB, updated to 4.1, and restored from my old device in iTunes, and now I cant get GreenPois0n or Limera1n to JB my phone after many attempts. Was wondering if (having exhausted other options) it had something to do with restoring my phone on 4.1 from device data saved in iTunes (phone was previously on 4.0.1 and JB'd w/ jailbreakme.com).

    Thanks.
     
  21. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #21
    how do I get the server back to normal?? My iunes cant connect to the server now
     
  22. outz macrumors 6502

    Joined:
    Jul 17, 2007
    #22
    i was attempting to do this, but i think cydia's shsh backup server is having issues. tinyumbrella keeps reporting this:

    10/16/2010 14:52:39.906 Asking CYDIA for SHSH blobs for iPhone4 4.1 (8B117)... 10/16/2010 14:52:46.484 HTTP STATUS:500 10/16/2010 14:52:46.500 Server-side error. Cydia is likely overloaded...

    10/16/2010 14:49:46.796 Processing SHSH Request... 10/16/2010 14:49:46.875 Asking CYDIA for SHSH blobs for iPhone4 4.1 (8B117)... 10/16/2010 14:49:57.984 This device isn't eligible for the requested build. 10/16/2010 14:49:58.000 CYDIA DOES NOT HAVE YOUR SHSH FOR iPhone4 4.1 (8B117) THERE IS NO WAY FOR YOU TO GET THEM. SORRY. YOU ARE JUST TOO LATE.

    i opted for cydia to auto backup my shsh back when i originally purchased this ip4... which appeared to be working last time cydia was reporting the shsh versions it had for me. i don't see how it's too late since apple is still signing 4.1 - cant seem to get tu to pull it from apple either.

    guess ill just try later.

    ---

    worked an hour or so later.
     

Share This Page