Iphone 4 4.01JB/unlock with carrier profile anomaly

Discussion in 'iPad Hacks' started by swwang, Oct 11, 2010.

  1. swwang macrumors newbie

    Joined:
    Mar 1, 2009
    #1
    I am from the US and got a legit AT&T Iphone 4 with 4.01 in early August, JB and unlocked with ultrasn0w. It worked fine in China with China Mobile (it showed China Mobile 7.0 carrier profile in settings-general).

    Then I needed to do a restore near the end of September; did restore to 4.01 with TU and JB/unlock.
    I activated with my AT&T SIM and the Carrier profile was AT&T 7.0 as expected; but when rebooted with China Mobile SIM card the carrier profile remained AT&T 7.0 and not the China Mobile 7.0.

    The phone works fine in Beijing but the carrier data portion would not when I am outside Beijing because I could not set the APN setting to "cmnet" because the AT&T profile does not have that option.

    Any ideas? could it be because the baseband was not restored due to error 1004 even though it is 01.59.00 from the start? I did not get any errors during the JB process back in August when Apple is still signing 4.01.

    I redid the restore several times with the same result. I had to use UT to kick the phone out of DFU mode due to the 1004 error.

    Scott
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    Shouldn't have to do anything with the baseband, I would do a "reset network settings" (if you haven't done so yet), with the China SIM in it. it should pick up the right settings from the network you are connected

    BTW, you may get more/better responses on the iPhone Hacks section of the forums
     
  3. swwang thread starter macrumors newbie

    Joined:
    Mar 1, 2009
    #3
    yes, I posted in the wrong forum...
    and YES, you are right, it now has China Mobile 8.1 carrier profile.

    Thank you very much for the pointer to reset network.

    Scott
     

Share This Page