iphone 4, 4.1, jb with greenpoison, "no sim card" please help

Discussion in 'Jailbreaks and iOS Hacks' started by Justinb51, Dec 1, 2010.

  1. Justinb51 macrumors 6502

    Justinb51

    Joined:
    Apr 9, 2010
    Location:
    Indianapolis, IN
    #1
    ok I have had my phone jailbroke with greenpoison since it was released and had have no problems.

    I got my wife an iphone 4 yesterday, and it had 4.1 on it. so i put her stuff on the phone and jailbroke it with greenpoison last night. i am at work currently but she said that all day she will send a text, or make a phone call and when she is done the phone says that there is no sim card installed. and of course there is. she then said that the only way to get it back to a working phone is to restart the phone, this fixes the issue most of the time.

    does anyone have any idea what might be causing this.

    installed is:
    sbsettings
    five icon doc
    3g unrestrictor
    lockinfo
    bitesms
    20 second lock screen
     
  2. AznHustler macrumors member

    Joined:
    Aug 11, 2010
  3. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #3

    Are you on an official carrier or are you trying to unlock?
     
  4. Justinb51 thread starter macrumors 6502

    Justinb51

    Joined:
    Apr 9, 2010
    Location:
    Indianapolis, IN
    #4
    i am on the official carrier, AT&T.

    I am going to try and reset the netwood settings.. but if you can think of anything else please let me know.
     
  5. Justinb51 thread starter macrumors 6502

    Justinb51

    Joined:
    Apr 9, 2010
    Location:
    Indianapolis, IN
    #5
    so i reset the netwook settings but that did not help. any other ideas guys?
     
  6. Justinb51 thread starter macrumors 6502

    Justinb51

    Joined:
    Apr 9, 2010
    Location:
    Indianapolis, IN
    #6
    ok so i tried to restore to 4.1, still said no sim. so i had to restore as a new phone with 4.2.1 and i am back up and running.

    guess she will have to go stock until an untethered JB comes out, not gonna deal with the tethered one. thanks
     
  7. jpetticrew macrumors 6502a

    jpetticrew

    Joined:
    May 13, 2009
    Location:
    Texas
    #7
    Did you try popping the SIM out, making sure it's seated in the tray properly, and putting it back in?

    I had a SIM card failure error one time and that fixed it.
     
  8. Justinb51 thread starter macrumors 6502

    Justinb51

    Joined:
    Apr 9, 2010
    Location:
    Indianapolis, IN
    #8
    Yes I did pop out the card and put it back in. I really have no idea what happened.
     
  9. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #9
    What kind of phone did your wife have before the iPhone 4? Do you have a data plan connected to the 4?
     
  10. alantor macrumors member

    Joined:
    Jun 15, 2010
    #10
    I had this same issue when I got my iPhone 4 on launch day.

    I think were was a manufacturing issue or something.
    I took it to the apple store and they gave me a new one with no questions asked once I told them what was wrong with it.
     
  11. Justinb51 thread starter macrumors 6502

    Justinb51

    Joined:
    Apr 9, 2010
    Location:
    Indianapolis, IN
    #11
    She had a 3GS with an unlimited data plan, which is carried over to the 4.
     

Share This Page