iPhone 4 5.1.1 update screwed up wifi?

Discussion in 'iOS 5 and earlier' started by pcpshortbus, May 9, 2012.

  1. pcpshortbus macrumors member

    Joined:
    Mar 23, 2008
    #1
    i updated OTA and now my wifi isn't connecting to my wifi shared from my macbook. the wifi selection just features a circling shape but never gives me a check mark next to the wifi name.

    anyone else having issues?

    anyone have a fix?
     
  2. Giuly macrumors 68040

    Giuly

  3. pcpshortbus thread starter macrumors member

    Joined:
    Mar 23, 2008
    #3
    yes, didn't help at all.

    i'll try restoring now.
     
  4. AlphaVictor87 macrumors 6502a

    AlphaVictor87

    Joined:
    Sep 7, 2011
    Location:
    Saint Louis, MO
    #4
    might be a problem with your actual wifi. I had that happen to me where my phone could see the wireless router, but when trying to connect it just kept spinning that wheel and didn't stop.

    After powering it off and on (the router not the phone) internet connection came back and the phone connected right away.
     
  5. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
    #5
    Also try resetting Network Settings. It might help to get rid of whatever setting is messing up your WiFi.
     
  6. drewdinardo macrumors newbie

    Joined:
    Nov 5, 2005
    #6
    This worked for me. Had same problem. iPad didn't work ( although iPhone did). Reset router and all is fine
     
  7. ixodes macrumors 601

    ixodes

    Joined:
    Jan 11, 2012
    Location:
    Pacific Coast, USA
    #7
    5.1.1 is working really well for me. Like mentioned earlier, I would reset the cable modem, then the router, being sure to unplug the power first for 30 seconds. Then do a complete reset.
     
  8. iShorty, May 12, 2012
    Last edited: May 12, 2012

    iShorty macrumors regular

    iShorty

    Joined:
    Jun 23, 2010
    Location:
    Nottingham, UK
    #8
    Getting the same issue ever since updating to 5.1.1 OTA. I've tried resetting the network settings, rebooting my iPhone, rebooting the router & modem and forget the wifi network but I'm still getting the same issue.

    Just a note, that I'm trying to connect directly to my router and not sharing via anything else like the original poster.

    A few users from other websites as well as Apple Support forums appear to be having the same issue.

    Update 1;
    Tried restoring my iPhone from iTunes, I attempted to restore my content via the iCloud but I wasn't able to get past the WiFi setup.

    Update 2;
    Downgraded to 5.1 and it was still having the same issue, so I restored my router to factory settings and it seems to of fixed the issue. No idea what happened, but all is good now.
     

Share This Page