iPhone iphone 4 6.0.1 redsn0w need help

Discussion in 'Jailbreaks and iOS Hacks' started by dazza07, Dec 9, 2013.

  1. dazza07 macrumors newbie

    Joined:
    Dec 9, 2013
    #1
    hiya,i have an iphone 4, basically I was on ios 7.0.4, I used ifaith to get my shsh blob from cydia which was 6.0.1, I downloaded that to my computer and made a ipsw to downgrade in iTunes.
    the downgrade process went ok, but I got stuck in dfu mode, nothing I could do was getting it out, so after a lot of messing around, I jailbroke using redsn0w and booted tethered.
    the iphone booted up with 6.0.1 software, but I had "no service"??
    ive been trying loads of fixes from youtube and google but im still stuck?
    I tried to install the evasi0n untether patch but that did not work, although it did install fine on my phone, when I turned my phone off it wouldn't boot back up.
    if anyone can help I would be much appreciated, I really wanted to stay on 6.0.1 so I could keep the jailbreak, but if I have to restore then so be it.
    I hope someone can help as im without a phone for last 2 days lol

    thanks a lot, take care
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    Did iFaith say that your 6.0.1 blobs are valid?

    Did you depend on ultrasn0w or a sim interposer to unlock the phone?

    I'd say try restoring to 7.0.4 and see how it goes. If it all works fine, try restoring to 6.0.1 again (assuming your blobs are valid)
     
  3. dazza07 thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #3
    hi thanks for reply, ive tried restoring and that's not working either? it extracts the software and backs up iphone but then iTunes says its stopped working and has to close?
    is there anything else I can try? im desperate

    thanks again
     
  4. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #4
    the problem is your iTunes version. you have to have iTunes 11.0.5 or older for the downgrade to work.
     
  5. dazza07 thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #5
    That's the thing I downloaded iTunes 10.5.4 to do the downgrade ,
    I had a old version of I faith to create the ipsw I think it was version 1.5.4.
    I tried to use a new version of ifaith to see if that would work but it says my aptickets are invalid??
    I don't know what to do anymore??
    I've been without a phone for last nearly 3 days
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    If iFaith says your aptickets are invalid, then that means your SHSH blobs for 6.0.1 are no good. You have to restore to the latest version (currently 7.0.4)

    Can you restore to 7.0.4 or are you even having troubles with that?
     
  7. dazza07 thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #7
    im having trouble restoring to 7.0.4 as well, I downloaded the newest iTunes when it prompted me to upgrade to 7.0.4.
    it will extract the software and start backing up the phone, then a box will pop up saying that iTunes has stopped working and needs to close???
    im at my wits end trying to figure out what to do? because at the moment I have a jailbroken iphone on 6.0.1 but have no service or carrier settings?
    I just wanna get this sorted, I feel like crying loool.
    its getting to the point where I don't think I can fix it and I will have to buy a nokia lumia 520 because it cheap, which I really don't want that to come to.
     
  8. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #8
    Update your iTunes' version before restoring to iOS 7.0.4

    Try a different computer to restore to 7.0.4
     
  9. dazza07 thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #9
    i did update to the newest itunes but it still wont work? does it have anything to do with my phone being on a tethered jailbreak? also what state should my phone be in to do the upgrade? normal mode or dfu mode?
    ill try on a different computer but im not holding much hope
     
  10. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #10
    Try DFU mode when restoring
     
  11. dazza07 thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #11
    ive tried that, ive tried normal, dfu and pwnd dfu mode and ITunes is still saying it has stopped working and has to close
     
  12. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #12
    Try a different computer and let me know how it goes
     
  13. dazza07 thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #13
    thanks for your replies, I will have to try a different computer tomorrow.
    so I reckon that I successfully downgraded with invalid shsh blobs? is that even possible?
    is there anyway to fix my phone if trying from another computer doesn't work?
     
  14. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #14
    It is possible to downgrade with incomplete blobs but you'll be stuck in soft DFU mode when you restart the device (so essentially a tethered jailbreak, except you'll be in that situation even if you didn't jailbreak)

    You would need to use redsn0w's just boot feature to kick it out of soft DFU mode
     
  15. dazza07 thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #15
    ok I didn't know that, ive read so much about trying to fix my problem the last 3 days my brain feels fried.
    what would be the reason as to trying to restore on another computer? is my computer broken?
     
  16. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #16
    It doesn't mean that your computer is broken but there's a possibility there's something wrong with iTunes on your computer or something on the computer that's messing up the restore
     
  17. dazza07 thread starter macrumors newbie

    Joined:
    Dec 9, 2013
    #17
    Hi again, thank you so much for your help.
    I actually brought a lumia 520 because I couldn't get to another computer to try the restore.
    Anyways my girlfriend took my phone to her mums house and restored it on her computer and it worked!!!
    So I am using the iPhone 4 again and will be hopefully returning the lumia.
    Once again thank you for your help, much appreciated ;-)
     
  18. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #18
    that's great you got the iphone 4 restored in the end!
     

Share This Page