iPhone 4 and my Data Connectivity Issues...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Arkanok, Sep 17, 2010.

  1. Arkanok macrumors 6502a

    Arkanok

    Joined:
    Feb 13, 2007
    #1
    As the title says, I'm using an iPhone 4 and for the past month or two, I've been having something of an on-going issue. Sometimes it's worse than other times, but recently I'm just getting real ticked that it's even happening to me and want to know if this is known or if I'm the only one having this problem.*

    Basically, very often (multiple times a day) I try to access something that uses the data and it just WON'T connect; what I have to do to fix it is toggle airplane mode on and off a few times, then usually it fixes it, but only temporarily.*

    What's the deal with this? Is this something that's the fault of iOS 4, or is this an issue with my carrier? By the way, I'm on Fido in Toronto, Canada.

    On a quick side note, lately (possibly near the 4.1 release) I noticed that my upload speeds and sometimes download speeds are damn slow. In fact, more times than not, when I try to upload a video or photo to a friend on "whatsapp" or even sending Otto dropbox, the upload is real slow, and most of the time it fails to upload all together. I don't know if this is a carrier thing or some nasty bug with 4.1. Any thoughts? Anybody else have these problems?*
     
  2. Arkanok thread starter macrumors 6502a

    Arkanok

    Joined:
    Feb 13, 2007

Share This Page