iphone 4 and push mail failed

Discussion in 'iPhone' started by threezero, Aug 6, 2010.

  1. threezero macrumors 6502

    Joined:
    Aug 22, 2008
    #1
    so I've notice that push mail on iphone isn't working. I'm using mobileme and i notice that i would only get push mail IF mail is open in the background. is this the way its suppose to work? I'm jb and this morning i restore -> jb -> setup as new phone and the push with out mail open seem to work for a few hours than its back to not getting any mail until i manually open the mail app or leave it on in the background... phone problem or mobile me???
     
  2. Mikey B macrumors 65816

    Mikey B

    Joined:
    Jan 4, 2008
    Location:
    the island
    #2
    First thing I'd check is to make sure you have Push turned on in your Mail Settings.

    I've had no problems with push on my mobileme and 2 exchange accounts.
     
  3. threezero thread starter macrumors 6502

    Joined:
    Aug 22, 2008
    #3
    yes i check i do have push on. and it work sporadically.

    i try deleting the account and readding
    nothing will make it work consistent except for leavning the mail app on in the background....
     
  4. threezero thread starter macrumors 6502

    Joined:
    Aug 22, 2008
    #4
    So nobody else on this foam have he problem? I left my mail app on last nite and everything push to my phone instantly. Did a Quick search on apple support and ppl seems to be reporting an opposite problem.... Mail not pushing when the app is running in the background..... =\
     
  5. Mikey B macrumors 65816

    Mikey B

    Joined:
    Jan 4, 2008
    Location:
    the island
    #5
    I saw you restored already. Did you do a DFU restore? If not, I'd maybe give that a try, set up as a new phone, add your email and see if push is working properly.
     
  6. djgulia macrumors 6502

    Joined:
    Jun 19, 2010
    #6
    Push has been working sporadically on some of my accounts and not at all on others. I've tried deleting the accounts and adding them back, changing gmail accounts to exchange, restoring, etc. I haven't figured out how to get it to work.
     
  7. Sweetbike40 macrumors 65816

    Sweetbike40

    Joined:
    Aug 29, 2007
    Location:
    NY/NJ
    #7
    I have this problem too and it's very annoying. I reset all settings and it then worked perfectly. 3 days later....back to not working. WTF? :mad:
     
  8. gtmac macrumors 6502a

    Joined:
    Jun 25, 2010
    #8
    Very similar experience here. No fix just sharing.
     
  9. Sweetbike40 macrumors 65816

    Sweetbike40

    Joined:
    Aug 29, 2007
    Location:
    NY/NJ
    #9
    I remember having problems like this with my 3G. Finally, it was working fine. Now here were are again with the same stinking mail issues. Seriously, this is pathetic. I love this phone, but this mail thing is getting old.
     
  10. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
    #10
    Same thing here with mine and my gf's i4. Weirdest thing! It was fine before ios 4.0.1
     
  11. Sweetbike40 macrumors 65816

    Sweetbike40

    Joined:
    Aug 29, 2007
    Location:
    NY/NJ
  12. wirelessmacuser macrumors 68000

    wirelessmacuser

    Joined:
    Dec 20, 2009
    Location:
    Planet.Earth
    #12
    Precisely.

    However it's important to note that Apple's morphed into an entertainment company, hence the name change from Apple computer. Apple's demographic doesn't care about email. They want shiny toys that impress their friends and bolster their egos. It's evident in the arrogant corporate culture.
     
  13. garethjs macrumors 6502

    Joined:
    Nov 11, 2008
    #13
    The same issue here with MobileMe.

    I did a restore with no apps synced over. For a week not a single issue with mail being pushed. I then copied my apps over and did what I needed. Day 2 and mail stopped pushing.

    I believe the iphone is runnng out of memory and killing processes. Mail should be priority but the OS is not maintaining that. Let's hope it's fixed in 4.1
     
  14. 3lionsbecks Suspended

    3lionsbecks

    Joined:
    Jul 19, 2010
    Location:
    Ontario, Canada
    #14
    If you really need a great device for mail and messaging I suggest you looking into a Blackberry. Its their specialty.

    Plus they just announced the new BB torch which has many consumer features as well as the great email service......perhaps it's a good compromise for you?

    For a pure communication machine I suggest the new BB Bold. It's awesome. But it does not have the multi-media capabilities as the iPhone.
     
  15. Quaildog macrumors newbie

    Joined:
    Jul 5, 2010
    #15
    i dont think push has worked on my ip4 since i got it, been about a month. i always have to open up the mail app for it to download my new messages.
     
  16. djgulia macrumors 6502

    Joined:
    Jun 19, 2010
    #16
    I've had this issue right out of the box.

    I don't want a BB. If I did, I would have gotten one.

    For most of my accounts, I don't care if email is pushed, but for some I do, like my email account for the group I volunteer with. We communicate solely through email. I find myself going into the mail app at least every 1/2 hour to get new emails.
     
  17. threezero thread starter macrumors 6502

    Joined:
    Aug 22, 2008
    #17
    Just want to let u guysbknow I figure out why my ip4 ain't pushing. It was backgrounder. With that install mail won't push without it running in background. It will one time, after u open and close it it won't ti the next time j reboot ur phone. I posted this in the hacks sections and got 0 response. Could be I just didn't find the correct set combination of setting for backgrounder. But I uninstall it and mail is now pushing fine everytime running or not
     

Share This Page