Resolved iphone 4 black,32gb won't start, won't charge

Discussion in 'iPhone Tips, Help and Troubleshooting' started by avro707, Sep 26, 2011.

  1. avro707, Sep 26, 2011
    Last edited: Sep 27, 2011

    avro707 macrumors 6502a

    Dec 13, 2010
    my iPhone 4 black, 32gb won't charge, won't restart. It's running latest normal iOS (not jailbroken). It worked fine this morning, then I locked it (it had some 50% battery left).

    I got it out of my bag this afternoon and sure enough, it won't start, nor is it detected by the computer when plugging it into USB or charging it with the charger.

    I've tried:

    1. Pressing both home and power buttons for 10 seconds
    2. Pressing both home and power buttons for 12 seconds
    3. Pressing both home and power buttons for 30 seconds
    4. Pressing both home button for precisely 12 seconds then power button for seconds while being connected to the computer with iTunes running
    5. Charged for at least 10 minutes
    6. And all combinations of everything in between that I've seen written on Google and forums everywhere else. The only thing I've not tried is offering some sort of sacrifice to the Apple gods!

    The phone has been recently doing random reboots on its own with no reason too, despite a restore.

    If anyone has any other suggestions in the mean time, I'm happy to hear them. I'm unable to get to the Apple store soon, so if there is any trick that I've missed - it will be useful.

    Edit: This is resolved. I let the phone discharge. It seemed like it must have been in some form of powered state - because it was warm to touch. So leaving the battery to discharge, and then pressing the wake/power button caused it to show the flat battery warning. And when it did, I plugged it into the charger (from the power point) and it's now come back to life again.

Share This Page