iPhone 4 black screen, infinite DFU Loop

Discussion in 'iPhone Tips, Help and Troubleshooting' started by xms669, Apr 2, 2011.

  1. xms669 macrumors newbie

    Joined:
    Jun 30, 2010
    #1
    Hello everyone !
    I've bought a brand new(sealed box) iPhone 4 and gave it to a friend to jailbreak it.
    In this moment , the phone loops in DFU, it can't be kicked with any software such as Fixrecovery,iReb,Recboot,TinyUmbrella&so on. Everytime I connect the phone to PC,iTunes shows the device in "Recovery Mode" and TinyUmbrella shows:
    "04/02/2011 16:20:28.375 Caching shsh files... 04/02/2011 16:20:28.406 Found [0] shsh files to cache... 04/02/2011 16:20:28.421 Cached [0] shsh files 04/02/2011 16:20:28.421 You are using the current version of TinyUmbrella. 04/02/2011 16:20:28.421 Loaded History... 04/02/2011 16:20:39.875 DFU Device connected
    " - no exit recovery , no enter recovery available;
    I've got the blobs from the man , but the "Recent devices - iPhone" states "This device is NOT connected" no matter what i do *reseting with the home+power 10sec ect*

    The only way i can power the device is by launching redsn0w and boot pwned DFU;hitting restore will work with a custom ipsw , itunes displays"update complete, the phone is restarting" and the phone automatically enters in DFU again;Installing an original ispw gives me the 1013 error at around 70% on the phone.

    firmware 4.2.1
    bb 03.10.01
    ps: if i remove the 127.0.0.1 gs.apple.com , TU won't work anymore and itunes will start "Error-ing"
    if i delete all the lines without # and save the hosts.umbrella and hosts file , itunes gives the error " the update iphone server couldn't be contacted"

    Did i brick the phone ?What are my options ?

    Thanks in advance and pardon me for my gramatical errors.
    XMS
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Currently, Apple stops signing 4.2.1. Therefore, you can only restore it to 4.3.1 Apple official firmware.

    Since you have TU on your machine, even you modify the host file. It is still point to your machine and not Apple. So, follow the following;

    1. Open Tiny umbrella
    2. click on advance tab
    3. Uncheck "Set host to Cydia on exit"
    4. Click apply changes at the bottom lower right corner
    5. Exit tiny umbrella
    6. click restore from Itunes.
     
  3. xms669 thread starter macrumors newbie

    Joined:
    Jun 30, 2010
    #3
    i have the shsh saved ... but it can't help because TU sees the device as disconnected * and connected in DFU, practically invisible for TU )
     
  4. sagarsamtani macrumors newbie

    Joined:
    Feb 15, 2011
    #4
    @xms669.... I have got 100 percent same problem brother.. From A to Z ... Even i got same iphone4 with same firmware and ios4.2.1
    Tried eveything fixrecovery..ireb...tinyumbrella.. But still no luck..
    Did u try to instal ios4.3.1 .. Did u find any solution?
    Plz plzzzz let me know..i will be soo much thankfull
    If possible reply me at sagar12pk@gmail.com
     

Share This Page