iPhone 4 Bluetooth off = SB crash?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by coonsie, Aug 20, 2010.

  1. coonsie macrumors newbie

    Joined:
    Nov 30, 2009
    #1
    I have a JBed iPhone 4 running 4.0.1 and got myself into repeated SpringBoard crashes before I could figure out how to get out of mobile safe mode...

    Narrowed it down to bluetooth being off and I was hoping someone could help. I'm sure this doesn't affect everyone as I used to be able to toggle bluetooth off before with no problems (but I usually leave it on so I'm not sure at what stage this started and what I might have installed / changed to cause this behaviour)

    If bluetooth is on, I can boot normally and do everything as per usual. Bluetooth works fine (for both tethering and for handsfree). The moment I toggle it off (in SBSettings or from the Settings.app), SpringBoard crashes and I'm taken to safe mode.

    If I respring/reboot without re-enabling bluetooth, it crashes to safe mode again as soon as the lockscreen appears.

    I can enable / disable / enable bluetooth again and again in safe mode with no problems.

    I've tried disabling *all* mobile substrate dylibs and it still crashes.

    Here are the syslog and crashlog from the CrashReporter app:
    http://members.optusnet.com.au/juhn/i4crash/syslog.txt
    http://members.optusnet.com.au/juhn/i4crash/crashlog.txt
    They are logs of the crash with all MS extensions disabled.

    I've tried doing a "reset network settings" and still no-go.

    I'm sure I could just do a full restore, but I'd rather not and try figure out the cause of the problem instead; so can anyone offer up any suggestions?
     
  2. FalkSD3 macrumors newbie

    Joined:
    Aug 23, 2010
    #2
    I have exactly the same problem (just glad it's not the other way around!) and though I can't tell what exactly is causing it, I have a hunch that it may be "TetherMe".

    The crashing started shortly after I installed it and all that's missing is uninstalling it for confirmation. I didn't yet do so because BT needs but little power and doesn't cause any problems when kept running all the time.

    Let me know if you are also using "TetherMe" and we may be one step closer to fixing this.

    Update: I just read in the comments on this page that disabling the "Tether" toggle may fix the problem. Will try to do so tonight when I get home and let you know the result.
     
  3. coonsie thread starter macrumors newbie

    Joined:
    Nov 30, 2009
    #3
    Bloody fantastic.
    I'm not using TetherMe because my carrier is generous enough to allow tethering free of charge (Telstra in Australia).
    What I didn't like was USB tethering becoming active whenever I plugged in to sync so of course I installed the Tether SBSettings toggle.
    Just deactivated the toggle and I can now power bluetooth on/off without any problems.
    (though I'll probably just leave the toggle enabled as I toggle tethering more often than I toggle bluetooth (never))

    Thanks and nice find, was doing my head in.

    Further followup:
    "SBSettings Tether Toggle" v1.0-1 by Ryan Petrich (BigBoss repo) is the one that crashes SpringBoard.
    "SBSetting Tethering Toggle" v1.0.1 by Filipe Pina (BigBoss repo) however works fine.
     
  4. FalkSD3 macrumors newbie

    Joined:
    Aug 23, 2010
    #4
    Confirmed, disabling or removing Ryan Petrich's Tether Toggle fixes the problem. Thanks for hinting at the other version: Works like a charm!
     

Share This Page