iPhone 4 Boot Loop

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Komentra, Dec 20, 2013.

  1. Komentra macrumors member

    Joined:
    Jan 27, 2011
    #1
    So a couple weeks back I dropped my iPhone 4 and cracked the back glass and noticed the next morning the phone wasn't working at all. I forced it into recovery mode by holding the home button down while connecting it to my Mac and was able to restore it and everything worked! Then about a week later it went black again.

    When plugged into the computer in non-recovery mode it just shows the apple logo and continues that loop.

    When plugged into the computer in recovery mode it shows the little icon telling me to connect it to iTunes but when I try to restore in iTunes it says "The iPhone could not be restored. This device isn't eligible for the requested build". I clicked More Information and tried the troubleshooting tips they suggested and tried restoring again and just got unknown error (2001) and tips Apple gives for that eror is what I already been trying all along.

    When unplugged it's just a black screen.

    Just wondering if anyone knows of a fix? I'm thinking maybe I just need a new battery but thought I'd post here and see if there's something I might be overlooking before purchasing that.

    Thanks
     
  2. sensi277 macrumors newbie

    Joined:
    Oct 25, 2013
    #2
    Same problem here...

    I'm also having this problem, on a 3GS, after attemping to downgrade baseband from iPad baseband in redsn0w. It gave me an error, about booting the device up and powering down, and trying again. Went to do that, now in boot loop. It goes to apple logo for a while and then the screen goes dark for 2-3 seconds. Repeat. I've tried TinyUmbrella's fix recovery loop function, nothing. Tried "exit recovery" in TinyUmbrella. Tried forcing into DFU mode, and trying to downgrade baseband again. Still nothing. Also tried "just boot". Nothing seems to work. As a last resort, I put the device into Recovery mode and tried restoring to stock iOS 6.1.3. Says "The iPhone "iPhone" could not be restored. This device isn't eligible for the requested build."
     
  3. Komentra, Dec 28, 2013
    Last edited: Dec 28, 2013

    Komentra thread starter macrumors member

    Joined:
    Jan 27, 2011
    #3
    Just a update for anyone who may see this and have similar problems. I went ahead and bought a new battery and installed it and it's working like new.

    EDIT: Just noticed with the new battery the phone isn't charging past 29%. Anyone have any idea what that could mean?
     
  4. The Doctor11 macrumors 603

    The Doctor11

    Joined:
    Dec 15, 2013
    Location:
    New York
    #4
    Did you have apple replace the battery?
     
  5. Komentra thread starter macrumors member

    Joined:
    Jan 27, 2011
    #5
    No. I did it myself. The battery won't charge though although the phone says it's charging. The cables I have all work and everything because I restored the phone in iTunes. I was afraid it may be the dock connector but since iTunes detects the phone I am assuming that's not the case? Anyone know?

    Anyways, I'm thinking maybe I just bought a bad battery. I did buy the cheapest one on eBay which was like $5. I went ahead and ordered a $30 one from ifixit and hope that will fix the problem.
     

Share This Page