Iphone 4 - browsing and email not working properly

Discussion in 'iPhone' started by huntli77, Jun 5, 2011.

  1. huntli77 macrumors newbie

    Joined:
    Jul 17, 2010
    #1
    For the last week my Iphone4 has been extremely slow when using safari or receiving email...sometimes it times out completely. this happens over 3g and sometimes wifi. Is this an Iphone problem or At&T service problem?
    any suggestions on what to do?
    I'm using version 4.3.3

    thanks in advance
     
  2. Qman89 macrumors newbie

    Joined:
    May 24, 2011
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8G4 Safari/6533.18.5)

    Have you tried closing all the apps and then turn of the phone and back on again?
     
  3. huntli77 thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    #3
    I have shut down many times but I don't think all the apps were closed individually. I will try that.
     
  4. huntli77 thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    #4
    Tried that but not much better. 3G is so darn slow! I live in a area that is well covered. Very frustrating!

     
  5. Qman89 macrumors newbie

    Joined:
    May 24, 2011
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8G4 Safari/6533.18.5)

    Yeah I just wasn't sure if it was your coverage cause you mentioned it happened over wifi. I would download a free speedtest app and test the 3G speed if the "download" is at least 1mbps you are good and should back up your phone and set it up as a new phone but if it's way below 1 Mbps then that's your answer!
     

Share This Page