Iphone 4 can't download later version of Garageband ??

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Jamesy97, Mar 24, 2015.

  1. Jamesy97 macrumors newbie

    Joined:
    Mar 24, 2015
    #1
    I'm pretty frustrated atm. I've been trying for a while to get garage band on my Iphone 4 as I was unaware that the update causes this app to require ios 8 before I bought the phone and it can only go up to 7. I still can't even understand why Apple made it like this ? it's completely pointless and it seems to me it's just an abrupt way of saying "buy an Iphone 6". I also thought you have the ability to download later updates of the app to suits your ios ? after failing to buy it through the app store on my phone I tried on itunes on my PC after looking up method on how to get around this. I still can't manage to put the app on phone without being greeted with "this app requires IOS 8". There's no options at all for downgrading even through itunes ?

    Cheers.
     
  2. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #2
    when you go to download an app where its latest version requires iOS 8, is should/will prompt you stating that it will attempt to download the most recent version compatible with your OS.

    im running iOS 6.1.3 on my iPod touch 4th gen and recently downloaded Twitterrific onto it and was prompted with this. it ended up downloading a slightly older version of it because im running the older OS.

    there comes a time where due to hardware limitations, certain OS versions cannot run well or at all on the device. the iphone 4 is "old" enough now where devs have moved on to the newer platforms. its not necessarily that they choose not to support older iOS versions, but that they cant due to hardware limitations on the older devices.
     

Share This Page