iPhone 4 Connection Timeout in Personal Hotspot

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iPadPhone, Apr 1, 2011.

  1. iPadPhone macrumors member

    Joined:
    Mar 19, 2011
    #1
    Purchased the tethering bolt-on for my iPhone today and it has all activated fine (carrier is O2-UK). I connected it up to my MacBook and it tethers fine via usb but if I try and use the Wi-Fi option I manage to find the iPhone on my Mac but when I enter the password and try to connect it always times out.

    I have tried restarting the iPhone as well as resetting the network settings but still no luck :(

    Any ideas?

    Thanks.
     
  2. Eric-PTEK macrumors 6502

    Joined:
    Mar 3, 2009
    #2
    Same problem here. MB Air 13" and it does the same thing. Reset the phone, still the same problem. Sometimes rebooting both, or removing the profile from the Airport util will solve it but not all the time.
     
  3. iPadPhone thread starter macrumors member

    Joined:
    Mar 19, 2011
    #3
    The strange thing is it works perfectly fine on the iPad, but not the Mac.
     
  4. cstreet macrumors newbie

    Joined:
    Apr 6, 2011
    #4
    Some here, iPad no problem MacBook most of the times timeout :mad:
     
  5. windelicious macrumors newbie

    Joined:
    Apr 15, 2011
    #5
    bluetooth works

    I had the same problem then went into airport and found it was only connected via USB. If you set up your bluetooth in network preferences, it will pair it via bluetooth so you don't have to tether via USB. I still can't connect via wifi though. Now that I'm set up on bluetooth, my phone doesn't even show as a wifi network.

    Hope this helps.
     
  6. DIESEL-X macrumors newbie

    Joined:
    Dec 4, 2009
    #7
    Problem still persists months down the line....

    Months down the line from this thread date and yet the 'Connection Timeout' problem when using the iPhone's WiFi for tethering, unbelievably still exists.

    As with other fellow users here, I am able to use tethering through the iPhone own sync-USB cable but NOT through the iPhone WiFi 'personal hotspot' feature. This is quite frustrating and extremely poor of Apple not to have addressed and fixed this for months (4 months from dat of this thread.

    I must point out that the iPhone's Personal Hotspot DID previously WORK flawlessly for me when I was running iOS 4.2.5 (or 4.2.6) on my iPhone 4 and because I was so happy with the Personal Hotspot feature, I then decided not to update for some time because a little voice inside me said not to do so incase it upset that feature. Eventually I gave in and stupidly did an iOS update and jumped from iOS 4.2.5 (or 4.2.6) up to the then current iOS which I believe towards the end of July 2011 was iOS 4.3.4 and thats when it all went wrong.

    Unfortunately it will remain broken unless Apple finally fix the problem or there's a way to restore the iPhone 4's iOS back to v4.2.5 instead of 4.3 which is mostly available on the internet but is not far back enough (personal hotspot was introduced in version iOS 4.2.5 and tweaked in 4.2.6). I'd prefer not to have to use the cable link for tethering (with iPhone remaining cabless in my pocket) and not having to use bluetooth because I have the Apple bluetooth keyboard and magic mouse constantly using the bluetooth connection on my MacBook Pro.

    Any suggestions on a restore to iOS 4.2.5 and/or then possibly 4.2.6 ? (depending on which was the happy one as it was one of those two that functioned flawlessly). I'd imagine the baseband would have to be addressed as well.
     

Share This Page