iPhone 4 Contact Book error

Discussion in 'iPhone Tips, Help and Troubleshooting' started by postma, Aug 6, 2012.

  1. postma macrumors newbie

    Aug 6, 2012
    Hey everybody. I just got a new iPhone 4 a few weeks back and since I got it there has been no issues. Today I logged into my email (using Hotmail), then I was prompted with a screen that had on and off switches saying "Mail" "Contacts" "Calenders" and "Reminders". I assumed this meant it was going to sync with my email, so I switched the "Contacts" button from the default "on" to "off". After doing this, I lost my contacts. Losing my contacts is no big deal as I can replace them, however, now when I go into my contact book, my contacts are no longer sorted. For example, if I have 2 contacts with the names "John Smith" and "Rob Brown", they appear just on top of each other. They are not sorted by name any more like they should and had prior to this. Any idea how to help? Thanks
  2. Troneas macrumors 65816


    Oct 26, 2011
    At the alternatives section.
    Not sure what the problem might be but syncing to hotmail has only brought me headaches in the past, with double entries, contact losses and contact photos not properly centered (although i think this last issue had more to do with syncing between facebook and icloud).

    In any case my advice to you is not to sync with hotmail, reset all your contacts after backup and add contacts manually from then on.
  3. vettori macrumors 6502a

    Jul 10, 2008
    Italy, near Venice
    Have you tried to turn back the switch ON ? Open the settings app of the device, enter 'Mail,Contacts,Calendars', enter the Hotmail account and you'll find the switches.

    For the sort problem, are they sorted by surname instead of by name ? If yes, check the sorting settings in the settings app into 'Mail,Contacts,Calendars'.
  4. postma thread starter macrumors newbie

    Aug 6, 2012
    They're is no sort issue in terms of name and surname. The problem is that when I got to my contacts, they are not sorted at all. They are all just there, not sorted by letter at all or in any manner. I'll try to turn it back on though.
  5. mstrike macrumors newbie

    Oct 24, 2007
    If you are having contacts somewhere (icloud.com, mac address, backup) you will be fine!
    Restoring them and updating to icloud.com will fix half problem.
    Important, login to icloud.com to make sure the contacts are there!

    Other half and the main solution is clash between new separate settings in iOS 6 for icloud (above mail, contacts, calendars) and mail settings with icould account. Here are the steps:

    1. Delete first icloud account in mail settings (if you have all the contacts in icloud.com erase them from iphone)
    2. Delete the separate main icloud account
    3. Restart iPhone (just in case, but might not be necessary)
    4. Enter the user name and pass in the main icloud account
    5. You should have now synced all the contacts from your icloud.com

    This worked for me!

Share This Page