iPhone 4 Crashing on iOS 4.3.5

Discussion in 'iPhone' started by drewsky5, Jul 25, 2011.

  1. drewsky5 macrumors member

    Joined:
    Jun 6, 2008
    #1
    Hey all. I just updated my brother in law's iPhone 4 to iOS 4.3.5, and it worked great for a few minutes, but now it does nothing but crash almost every app the second that it is opened. I've restarted it both doing a soft and a hard restart several times, but no fix. Do I have any other choice than to do a restore? I'd rather not, because his phone is backed up on his work computer, and he won't be able to do it on his own.

    TIA for any help!
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #2
    I've had the same think happen to me several times before, its not a 4.3.5 issue because its been happening to me for a few months now whenever I restored my iPhone to new or from a back-up.

    The only way I was able to get the apps to work was to re-download the apps directly from the App Store on the iPhone (Do not add transfer apps from the iTunes).

    Though the only thing that fixed the problem completely was getting my iPhone swapped at the Apple Store (I went in for a different issue, but getting it swapped did my this issue go away).
     
  3. Shawnpk macrumors 6502

    Joined:
    Jan 13, 2011
    Location:
    Los Angeles, CA
    #3
    This just happened to me last night on both my iPad and iPhone. What worked for me was downloading a new app (I chose a free app of course). Once the app downloaded, everything was back to normal. I did have a small problem where the iPhone was showing it was connected to my wifi network but the App Store wouldn't ask for my password to download the app. I just reconnected it to my MacBook and that solved the problem.
     

Share This Page