iPhone 4 displaying No Service/Searching... After Unlock

Discussion in 'iPhone' started by Actualpimp, Jul 23, 2015.

  1. Actualpimp, Jul 23, 2015
    Last edited: Jul 23, 2015

    Actualpimp macrumors newbie

    Actualpimp

    Joined:
    Jul 23, 2015
    #1
    Friends, please help me out here!
    I just recently unlocked a phone I bought from a friend. When I got it unlocked, my phone worked perfectly until a few hours later, I noticed my phone said "No Service" and switched over to "Searching..." over and over again.

    Here are a couple things I've tried:
    1. Turn on/off Airplane Mode
    2. Reset Network Settings
    3. Turn on/off Cellular Data/Roaming Data
    4. Remove and inserted SIM card
    5. Restarted my iPhone

    I heard about jailbreaking the phone to resolve the issue, but I don't think I want to do that unless that's my last resort.

    Relevant information:
    - The phone was locked to Telus before
    - Was working on the Bell Carrier for a while until this problem occurred
    - This is an iPhone 4
    - Modem Firmware: 04.12.09

    Thanks for your time! Cheer.
     
  2. Chatter macrumors 6502a

    Joined:
    Jun 10, 2013
    Location:
    Uphill from Downtown
    #2
    Did you get it unlocked from the carrier or 3rd party? It could be blocked from the carrier end (like someone reported it stolen) though if its a friend, this seems unlikely.
     
  3. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    Whatever you heard is very likely out of date and related to software unlocks. Software unlocks can only be applied if a phone is jailbroken.

    This is irrelevant then to your problem because your phone is already unlocked.

    Additionally, software unlocks have not been made or updated for over four years. It doesn't apply any more. The ability to call your carrier or buy an unlock online killed software unlocks.
     
  4. Actualpimp thread starter macrumors newbie

    Actualpimp

    Joined:
    Jul 23, 2015
    #4
    Yea, I actually unlocked it through Telus with my friend.
     
  5. Actualpimp thread starter macrumors newbie

    Actualpimp

    Joined:
    Jul 23, 2015
    #5
    I totally agree with you.
     
  6. silverblack macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #6
    Put a telus sim back to see if the phone works.
     

Share This Page