iphone 4 doesn't connect to itunes or computer

Discussion in 'Jailbreaks and iOS Hacks' started by nydevil, Jan 10, 2012.

  1. nydevil macrumors newbie

    Joined:
    Jul 20, 2008
    #1
    ok, now i think i ruined it because it's my ports perhaps.

    i jailbroken my phone, and i'm used to it. one thing to mention was when i restored it on itunes to 5.0.1 it said error 6(or 9) i don't remember.. but when it was all done, it was firmware 5.0.1 and then i jailbroke it with redsn0w.

    but i did install libusb0 and i think that's my problem.
    though i believe i removed it from my system.. but i'm not entirely sure.

    i really think it's my ports, but it's only when i plug my iphone in my computer. it's odd, when i do my computer will say something like "usb port X is not working".

    also to mention, the only way i can charge my iphone is with the wall charger.
     
  2. nydevil thread starter macrumors newbie

    Joined:
    Jul 20, 2008
  3. NanoNyrd macrumors regular

    Joined:
    Dec 1, 2011
    #3
    Have you tried putting the phone in DFU mode? In DFU mode the phone does not even read what software is on it, but expects to get everything it needs to boot and reinstall from the computer

    If it still does not work, it is either a hardware problem with your phone, or with the cable, or a problem with your computer.
     
  4. nydevil thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #4
    No there is nothing wrong with the phone. (i tried my first iphone and it doesn't work, and my ipod).

    it's the ports.

    everytime i put my phone in, it'll sometimes go in itunes.. then it'll disconnect fast, then all my usbs will lock up.

    I uninstalled libusb and it still isn't working, all the usbs work perfectly, except when i plug my iphone in.
     

Share This Page