iPhone iPhone 4 Downgrade 6 -> 5.1.1 -- ERROR 21

Discussion in 'Jailbreaks and iOS Hacks' started by StevenQ, Sep 22, 2012.

  1. StevenQ macrumors newbie

    Joined:
    Nov 12, 2011
    #1
    Hi everyone,

    I'm really frustrated. By a dumb mistake, I today destroyed my jailbroken 5.1.1 installation and thought I could still restore to 5.1.1. Sadly, i discovered that Apple won't sign any longer. I did save my 5.1.1 blobs locally as well as on Cydia before so i thought it's still possible to restore somehow. (I'm on iP4 GSM)

    First tried to restore to 5.1.1 via TinyUmbrella but soon found out it doesn't work for 5.x firmwares (I'm not too familiar with that :D). So I tried restoring with redsn0w - "Restore" only for A5 devices. Then found out that i have to create a custom IPSW of my original 5.1.1 (that leaves out baseband stuff i suppose), then "stitch" the custom one to my saved 5.1.1 blobs. So i did that.

    Then put my iPhone into PWN DFU mode and opened iTunes. ALT + Restore, chose the edited IPSW and waited. It said "preparing for restore" several times with fast filling loading bars. The iPhones screen turned on again, Apple logo showed up. It still said "preparing..." for some more seconds, then kicked me out with a "21" error. I'm completely desperate and confused. Tried everything several times, as described above. I don't know what to do any more.

    Can anyone help me? Is it true that if i get the 21 error that i have a faulty device? Please someone enlighten me, i appreciate any help. I can't live with iOS 6 with all its design faults, sluggish performance, jb bugs and the buggy maps i rely on pretty often.

    /e: tried restoring with and without the TSS server running, same error however. So it can't be a "hosts"-conflict here.

    iPhone 4 GSM
    Mac OS X 10.8.2
    iTunes 10.7
     
  2. StevenQ thread starter macrumors newbie

    Joined:
    Nov 12, 2011
    #2
    Me again.

    I tried out "iFaith" in Windows, it only works for firmwares up to 5.0.1. So i prepared the 5.0.1 with iFaith and restored and it worked! Then i tried stitching the 5.1.1 IPSW with the Windows redsn0w, and restored afterwards. All worked well, until it came to "Restoring firmware" and kicked me out with a -1 error. Had to restore to 6.0 b/c DFU mode wasnt functioning anymore. Did that, then made the IPSW custom (no baseband) and stitched, then tried to restore --> error 21 again. So i guess this must be a redsn0w problem? A fault in the process of making the IPSW "custom"? oh if anyone can help me please...
     

Share This Page