iPhone 4 - downgrade to 5.0.1 gives error 1600

Discussion in 'Jailbreaks and iOS Hacks' started by MoodyM, May 13, 2012.

  1. MoodyM macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #1
    Trying to downgrade iPhone 4 on stock, non-jailbroken 5.1.1 to 5.0.1.

    I opened redsn0w 0.9.11b1, and chose "Stitch", browsed to the official 5.0.1 ipsw, and let redsn0w stitch my blobs from Cydia (I've also tried all of this using local shsh blobs, got the same error).

    I set my hosts file to 74.208.105.171 gs.apple.com, and used redsn0w to put the phone in pwned DFU mode. I the use iTunes to Restore, browsing to the newly created ipsw, and after the "Extracting Software" stage, I always get iTunes error 1600.

    Any idea what I'm doing wrong?
     
  2. noiceT macrumors 6502a

    Joined:
    Jul 7, 2008
    Location:
    Catalina Wine Mixer
    #2

    I was facing a similar issue earlier. To start maybe download the latest redsnow. Not necessary if no need to preserve bb, but this is what worked for me: stitch the original fw. Then create custom fw from the stitched version. Must go in this order, the reverse always gave me an error 21 or 1600 (depending on the dfu mode).

    Try that and see if works. Also another thing to check is if you are running the latest itunes, which sometimes can hang things up as well.
     
  3. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #3
    You could try iReb instead of redsn0w. Also, clear your hosts. If you stitch your blobs to an IPSW that step isn't necessary.
     
  4. krayziekray macrumors 6502

    Joined:
    Sep 24, 2008
    Location:
    127.0.0.1
    #4
    I had the exact same issue.

    Get yourself on a Windows machine and use iFaith ... worked for me first time round. Not sure what it is but the Redsn0w ipsw wouldn't work for me. Created a custom one using iFaith and restored. Worked like a charm ... I'm on 5.0.1 now and ready to jailbreak.

    Good luck
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    Did you check to see if your 5.0.1 hash includes the APTicket also ?
    Redsn0w-Extras-SHSH-Verify
     
  6. krayziekray macrumors 6502

    Joined:
    Sep 24, 2008
    Location:
    127.0.0.1
    #6
    Yes my SHSH file did include APTicket.

    Turns out what I needed to do was first create a no baseband version of the ipsw as you cant downgrade the BB and thus the downgrade was failing. Once that was done I would needed to stitch my SHSH files to the ipsw and then restore using that firmware ... so that's the fix without the use of iFaith (well for me at least) :rolleyes:

    Hope that helps the OP.
     
  7. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #7
    The 1600 is because you are pointing to cydia, you need to point to apple to restore, remover the 74.208.105.171
     
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    When hashes are stitched to IPSW, the host file is irrelevant since the necessary authentication is built inti the IPSW.
     

Share This Page