Iphone 4 Error 20 When Restoring with ios5 Beta

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ArtlessOne, Jul 16, 2011.

  1. ArtlessOne macrumors newbie

    Joined:
    Jul 16, 2011
    #1
    Sorry if this has been covered, I couldn't find it in the search.

    I had my iphone 4 on the beta ios5 software with no issue from the first release in June through the latest. However, I got a replacement phone yesterday and after having my UDID registered I tried to restore the software.

    For some reason, now every time as it gets to the "verifying with apple" the restore fails with an error 20 and leave the phone in recovery mode. I've tried multiple times, verified that my UDID is registered on the developers' account correctly, tried different downloads of the firmware, and still the same error. The only bit of info I could glean from the more info link to apple's website is that it has something to do with security software but I have no third party software on my machine and it worked fine with the previous unit.

    The kicker of course is that all my backups are incompatible with the old software so I need to get it restored to the beta so I can recover my data.

    Any ideas appreciated, many thanks!
     
  2. Macipadiphone macrumors newbie

    Joined:
    Jul 17, 2011
    #2
    ios5 beta update error 20

    i tried the same thing with my ipad 2 yesterday and got the same error. did you by any chance update to ios 4.3.4 before trying to do the ios5 beta update? I did do the upgrade to 4.3.4 first which is why i'm thinking i got the errors. i'm wondering if the ios 5 files on the dev site only let you upgrade from 4.3.3 to ios 5 and not from ios 4.3.4 to ios 5 as yet. if you look at the dates on the ipsw files they are dated before the 4.3.4 update even came out.
     
  3. PapaJoey macrumors newbie

    Joined:
    Jul 17, 2011
    #3
    4.3.4

    I actually did upgrade to 4.3.4 just before attempting the restore to 5.0. That has to be the issue. Any workarounds you know of?
     
  4. Macipadiphone macrumors newbie

    Joined:
    Jul 17, 2011
    #4
    I think it will be a matter of waiting for apple to post some new ipsw files up to site.
     
  5. Sansibar macrumors newbie

    Joined:
    Apr 4, 2010
    #5
    Had the same error (20), going to DFU mode helped:

    1. Press both power button and home.
    2. After 10 sec first release the power button, then the home button.
    3. The screen of the iPhone should now be blank and not have the iTunes connect.
    4. Restore worked in this state for me...
     
  6. Macipadiphone macrumors newbie

    Joined:
    Jul 17, 2011
    #6
    yep, good advice sansibar - going into dfu mode first worked for me as well. ipad done, now about to do the same on iphone 4 and apple tv 2.
     
  7. Jimmy Guphanti macrumors 6502

    Joined:
    Mar 29, 2011
    #7
    Hello,

    I am in exactly the same situation, and I just did the DFU mode, which gets the iPhone 4 past the verifying with apple screen, and then it gives me error 1600 when it starts the restore. Any ideas? It is the CDMA version
     
  8. The Tos macrumors 6502a

    Joined:
    Jan 5, 2011
    Location:
    Buffalo, New York
    #8
    1600 is a common error. Try restarting itunes, switching USB ports or just restart your whole computer.
     
  9. PapaJoey macrumors newbie

    Joined:
    Jul 17, 2011
    #9
    Error 14

    I attempted a restore from DFU mode and about halfway through I got error 14. I tried again on my 24" iMac using another 30 pin cable, another USB port and a 4th time after restarting the machine with the same result. Any suggestions?
     
  10. tedgruber macrumors newbie

    Joined:
    Jul 18, 2011
    #10
    Do I put it in DFU mode before hitting the restore button on itunes?

    If you can help that would be appreciated.

    Thanks
     
  11. aeolian20 macrumors newbie

    Joined:
    Jul 19, 2011
  12. aeolian20 macrumors newbie

    Joined:
    Jul 19, 2011
    #12
    BTW, I put the phone in DFU right before step 6 (hitting 'restore)
     
  13. jimmy9224 macrumors newbie

    Joined:
    Jul 19, 2011
    #13
    error fix

    Hello I had the same error and was on 4.3.4 on an ipod 4th gen.
    What I did was as follows:
    1.downgraded my itunes to 10.2
    2.downloaded 4.3.3 firmwire from a google search
    3.control+restore find the update and wait till its done
    4.upgrade both itunes to itunes beta 10.5.0.48
    5.download 5.0 firmwire from online
    6.finally put the idevice in dfu mode and restore!
    This worked for me and hopefully it'll work for you!
     
  14. mczenko macrumors newbie

    Joined:
    Jul 21, 2011
    #14
    Works ! Thank you.

    I had the very same problem. I upgraded to iOS 4.3.4 on iPad and iPhone and then wanted to install iOS 5 beta 3. Thanks to what I read on this thread I was able to proceed :). Indeed putting iPad in DUF mode was the way to go. Step by step instructions follow:

    1) Starting point: iOS 4.3.4 on my iPad.
    2) Hit <option> Restore and select the new iOS 5.0 beta 3 firmware file.
    3) iTunes is validating with Apple, etc, and then I get the error (20) message. At this moment iPad just shows the picture indicating that you should connect it to iTunes. This is NOT DUF yet.
    4) Press the <power> and <home> buttons simultaneously and count to around 7 (at this moment your connection to iTunes should be lost and your iPad's screen will turn black).
    5) Release the <power> button but keep pushing the <home> button till the connection with iTunes is back.
    6) Release the <home> button.
    7) Your iPad screen should be still back, but iTunes will be saying you are in recovery mode.
    8) Now <option> Restore and select your iOS Beta 3 firmware file.
    9) No it should work.

    I saw some questions about when precisely you should put iPad into DUF mode. It does not really matter. Nothing wrong should happen to your iPad. When it is in DUF mode iTunes will always let you Restore. I was pushing the <power> and <home> buttons several times because I could not get the right timing.

    It worked for me.

    Thanks for your help guys !
     
  15. Dave Felix macrumors 6502a

    Dave Felix

    Joined:
    Apr 9, 2011
    Location:
    Scranton, Pennsylvania
    #15
    Im having the same damn problem i cannot restore my iphone back to ios 4.3.3
    please let me know how else it can be solved.
     
  16. vanimox, Jul 23, 2011
    Last edited by a moderator: Jul 23, 2011

    vanimox macrumors newbie

    Joined:
    Mar 21, 2009
    #16
    try this, i had the same problem a few weeks ago and this completely solved it. Press and hold the home and power for 30 seconds while the phone is plugged into the computer. Then continue holding the power and release the home for a few seconds. (im assuming you've already tried putting it into dfu and it didnt work?)
     
  17. commbot macrumors newbie

    Joined:
    Jun 26, 2010
    #17
    i hope there's a special place in hell reserved for whoever's responsible at apple for this. I can only restore to 4.3.4, despite having blobs for 4.3.3.

    my device, my command line. why is that so hard for them to understand?
     
  18. Dave Felix macrumors 6502a

    Dave Felix

    Joined:
    Apr 9, 2011
    Location:
    Scranton, Pennsylvania
    #18
    If you downgraded to 4.3.4 from iOS 5, cant you just download the iOS 4.3.3 and input it in iTunes?
     
  19. commbot macrumors newbie

    Joined:
    Jun 26, 2010
    #19
    Wish I could. I was trying to update from 4.3.2 to 4.3.3. The restore didnt work and I could only update to 4.3.4, and now I'm stuck. Getting a lot of 1013 errors at first, now seems to like giving me error 20. Now iTunes isnt even seeing the phone, even though its in restore mode.
     
  20. graymalkin2 macrumors newbie

    Joined:
    Jun 7, 2011
    #20
    See Apple's official instructions on how to put your iPhone into recovery mode. It's slightly different to some of the DFU instructions above. It also includes a link for Windows users on what to do if iTunes can't see the iPhone.
    http://support.apple.com/kb/ht1808

    The Guide to installing iOS 5 beta has been updated to include a note about error 20 and putting the phone into recovery mode.
     
  21. commbot macrumors newbie

    Joined:
    Jun 26, 2010
    #21
    OK, fixed now. You need FixRecovery4.3 to do it properly. Restore to 4.3.3 using TinyUmbrella shsh server. The restore gets past halfway and then fails with the phone going into recover mode. Put the phone into DFU and then run FixRecovery4.3 which will boot it out of recovery. Takes a few minutes but you can see the activity on the screen. TinyUmbrella's Fix recovery wasn't working correctly but the standalone program worked fine for me, restoring from 5b4. Goes without saying that you need your shsh blobs saved first. I used iTunes 10.5b4m bit I dont know if that would make a difference.

    Good luck
     

Share This Page