iphone 4 failure to restore! Error 2001, 2006

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ottoman8986, Jul 29, 2012.

  1. ottoman8986 macrumors newbie

    Joined:
    Jul 29, 2012
    #1
    iPhone 4 factory unlocked, not jailbroken, running iOs 5.0
    suddenly turned off and can not be activated just died.

    -I pressed the power and home button together holding for 10 seconds but didnt work.
    -I connected to mac and tried to restore but got message Error 2001 and 2006 everytime. Restoration cannot be completed and screen of the phone goes white like a flash and turns off.
    -I updated iTunes (iTunes 10.6.3)
    -I updated operating system of the computer. (OsX 10.8 Mountain Lion) I even downloaded the latest updates of it.
    -I tried different USB cable.
    -I restarted the computer several times.
    -I tried to restore on a different computer (on PC)

    All didn't work and I am now desperate.
    Anyone who can help me to fix this problem?

    Waiting for your suggestions, thanks.
     
  2. amwhitener macrumors newbie

    Joined:
    Aug 1, 2012
    #2
    I have had the exact same issue with my Iphone 4. I did EVERYTHING you did. I have been on the phone with an apple representative for 5 days now. He says it's a hub issue on my computer. However, I've used an HP and another Mac to do this and got the same problem. Sounds to me that it isnt an issue with my computer. I'm waiting to hear back from him...we will see if he will replace the phone or what?!
     
  3. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #3
  4. laserr macrumors newbie

    Joined:
    Jan 3, 2013
    #4
    I'm having exactly the same problem with my 3GS! However, I dont get error 2006 just 2001. I have tried everything you did without success but the problem is my phone is not under warranty any more so no idea what apple will do. Have any of you guys taken it into an apple store?
     

Share This Page