Iphone 4, form 4.0.2 to 4.1 sing TU, no unlock

Discussion in 'Jailbreaks and iOS Hacks' started by Powerm, Oct 11, 2010.

  1. Powerm macrumors newbie

    Joined:
    Oct 11, 2010
    #1
    Hi there,

    I bought and Iphone 4 in the USA, with AT&T sim. It came with 4.0.2 and 1.59 baseband, using TU I have saved my SHSG blogs and upgraded to 4.1, keeping 1.59 baseband. Using Limera1n I have performed JB and installed UltrasnOw via Cydia. All fine until here but it seems, but the unlock does not work...After reboot iphone says " waiting for activation" once, I can see different carriers but if I select one of them message like " "your cellular data settings are not valid". Is this due to a missing settting or unlock has not been performed successfully ? Has anyone been able to go from 4.0.2 to 4.1 and perform JB+Unlock with baseband 1.59 ???

    Thanks,

    Paul
     
  2. seniorp macrumors newbie

    Joined:
    Oct 11, 2010
    #2
    I am having the same problem.

    I have tried to reinstall ultrasn0w but with no luck. Anyone have a solution to this?
     
  3. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #3
    Did you by chance activate using the Phone Book Sim card. If so go to Pushfix in Cydia and install the Hactivation patch. That will solve your problem.
     
  4. seniorp macrumors newbie

    Joined:
    Oct 11, 2010
    #4
    Cydia is not allowing me to install the Hacktivation patch.

    But I am not getting the incorrect sim error, it is just not picking up my carrier with the sim inserted.
     
  5. Powerm thread starter macrumors newbie

    Joined:
    Oct 11, 2010
    #5
    Are we supposed to leave the At&T sim while JB'ing ? I've checked Pushfix, the 4.1 version will be out soon, for now Cydia won't add its repo...
    "Pushfix 2.0 currently does NOT support iOS 4.1 and it will be a few days until it does. Please be patient and do not install Pushfix 2.0 on iOS 4.1 at this time please."
     
  6. Powerm thread starter macrumors newbie

    Joined:
    Oct 11, 2010
    #6
    Seems Unlock doesn't work. I did an Erase all settings, Restored via TU preserving 1.59 baseband. Limera1n and Cydia have disapeared obviously, with the AT&T Sim inside I have the same error messages....
     
  7. Jordan921 macrumors 68040

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
    #7
    Shoulda listened to Musclenerd and waited for the new Pwnagetool
     
  8. Powerm thread starter macrumors newbie

    Joined:
    Oct 11, 2010
    #8
    Muscleberd was talking about the 02.10.04 BB , they are zillions of tutorials saying this ( see bloew ), are they all wrong ?????:mad:

    "if you have the iPhone 4 and you update its firmware to iOS 4.1, than it will also update the baseband from 1.59.00 to 02.10.04 which is not supported by the Ultrasn0w and you may lose carrier unlock.

    But you are able to protect your baseband from update and can preserve the 1.59.00 baseband, using the TinyUmbrella tool. Than it allows you to carrier unlock your iPhone 4 using Ultrasn0w."
     
  9. jeffjohnson macrumors newbie

    Joined:
    Mar 21, 2011
    #9
    Too bad they didn't support them. :mad:
     

Share This Page