iPhone 4(GSM) 5.0.1 jailbreak/restore problem. PLEASE HELP!!

Discussion in 'Jailbreaks and iOS Hacks' started by tco9, Dec 5, 2011.

  1. tco9 macrumors newbie

    Joined:
    Dec 5, 2011
    #1
    I recently updated to 5.0.1 after using a very successful ios4 jailbreak for months. I am now trying to jailbreak 5.0.1 using redsn0w 0.9.9b8, but having serious issues. After jailbreaking using this method cydia is blank and will not launch. I have tried jailbreaking multiple times to no avail. I have tried to restore and get the "device is not elligible for the requested build" error. I tried to fix this by deleting/reinstalling itunes and restart as well as fixing my host file by adding '74.208.105.171 gs.apple.com' and itunes itself will not restore to 5.0.1, as I get the same error message. Any ideas? Is there a way to completely wipe the phone and work from scratch without restoring?
     
  2. CC424 macrumors regular

    Joined:
    Mar 8, 2009
    #2
    You should be able to jailbreak it...just use extras in the redsnow menu and point to the 5.0 software not the 5.0.1.

    I was having the same problem and did what I just suggested and now my phone is jailbroken.
     
  3. tco9, Dec 5, 2011
    Last edited: Dec 5, 2011

    tco9 thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #3
    did that too, hasn't worked. should I try a different client or something? It did jailbreak, kinda, but cydia won't work. doing this all on a mac btw, but I have dual boot so I could do it on windows 7
     
  4. ylerT macrumors regular

    ylerT

    Joined:
    Jun 10, 2011
    Location:
    Las Vegas
    #4
    Sorry if you've tried this already but I don't see it mentioned. Usually the white Cydia icon is from not doing a tethered boot after the jailbreak. Have you tried this? If you haven't, just make sure you point to 5.0, not 5.0.1 like CC424 mentioned.
     
  5. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #5
    Correct, Cydia will be black when you jailbreak, you should be able to open it, it will crash the first time, then reboot your phone (Tethered since it is the only JB avaliable for it) and then Cydia should be there.
     
  6. tco9, Dec 5, 2011
    Last edited: Dec 5, 2011

    tco9 thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #6
    Just tried to jailbreak again using redsnow. I forgot to mention this earlier, but after every jailbreak attempts it boots without a tethered boot, by itself. This time it happened again, I tried to open cydia(blank white icon), which crashed.

    edit:Tryin more stuff still, have now turned on phone using a hard restart and I didnt need to boot tethered, blank phone problem fixed.
     
  7. tco9 thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #7
    So I have now tried using iFaith to downgrade, since I cannot restore in itunes at all. This did not work, and it would not download my shsh. I did download an shsh on my mac however and I think I will attempt to stitch it to an ios 5 .ipsw and then see if I can put this on my phone, and thereby be able to jailbreak in 5.0.0
     
  8. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #8
    Can you please try and use better grammar so it's easier to understand your problems?

    I'm not sure WHERE you are in this problem of jail breaking so just do the following, as you seem to have messed up your firmware;

    1. Put your device into DFU mode
    2. Restore it to 5.0.1
    3. Jailbreak it using redsn0w .9.9b8 (check my signature for links to software)

    redsn0w will guide you through the process of jail breaking.
     
  9. tco9 thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #9
    As aforementioned my phone will not restore in iTunes. I have already fixed my host file and attempted restore vie DFU mode. The error message is 'this device isn't elligible for the requested build'
     
  10. ylerT macrumors regular

    ylerT

    Joined:
    Jun 10, 2011
    Location:
    Las Vegas
    #10
    What firmware version are you trying to restore to? If you are trying to downgrade to something under 5.0, it requires you to have the SHSH files saved.
     
  11. tco9 thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #11
    just trying to downgrade to 5.0, but having little luck
     
  12. ylerT macrumors regular

    ylerT

    Joined:
    Jun 10, 2011
    Location:
    Las Vegas
    #12
    Just out of curiosity...why do you want to downgrade from 5.0.1 to 5.0?
     
  13. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #13
    You can't without blobs. Just go to 5.0.1 :confused:
     
  14. tco9 thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #14
    Yeah i was gonna try the blobs thing, but i don't have a 5.0 blob saved. Just found my problem. On boot, I had to point at the correct .ipsw, even though I had previously pointed at it for the jailbreak. That was such a HUGE waste of time
     

Share This Page