iPhone 4 Hangs on Restore 12x

Discussion in 'Jailbreaks and iOS Hacks' started by pasipple, Aug 4, 2010.

  1. pasipple macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #1
    My iP4 hangs at about 60% on a restore. I've tried a dozen times and it has run even overnight and will not get past the 60% each time.

    Called Apple and working with the tech couldn't solve it. They are overnighting a new iP4.

    In the meantime...today...I have no phone. Anyone have a suggestion. Apple had me login under a different user then I upgraded to 4.01 which went right into a restore and it hung at 60%.

    I think I got the first recordable software brick!

    Someone prove this can't be wrong. theLatinist? AppleJuiced?

    Note: Had to restore in the first place because while upgrading to 4.0.1 my internet service took a dump and it's been wanting a restore ever since.
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    when you work with the tech, did you get the phone into DFU mode?
     
  3. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #3
    Yes...no problem. Then you have to restore...then in hangs....

    Thanks....
     
  4. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #4
    It could be a bad memory sector (seen like it, based that it always reach the same %). Even when this was causes "while" you were jailbreaking, I believe it is unrelated, you would have got it with an official firmware upgrade, looks like a component issue. The phone its not "bricked" (i know how so many people here love that term), since you can get it to DFU and it is actually being recognized by iTunes, and you can start loading the fw on it.

    If that is the case, well it is just bad luck. sorry :(
     
  5. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #5
    Thanks....I can wait another day for the replacement. Could have been just bad timing and a hardware issue. But I have had no problems whatsoever since I got the iP4 at the initial release.

    Anyway, I've got to run some errands for a couple of hours. I'll check back and see if anyone else has a possible software solution?
     
  6. The General macrumors 601

    Joined:
    Jul 7, 2006
    #6
    Sounds like a hardware problem. Either with your computer, or with the iPhone.

    If the iPhone they send you does the same thing, then you know it's your computer that's the problem.
     
  7. Gatorac macrumors member

    Joined:
    Jun 10, 2009
    #7
    My 3GS started the same exact thing last night. I was upgrading from 3.13 to IOS 4.01. It hangs on the exact same spot at 60%. (Full Disclosure) My iPhone had been dropped in a small puddle and immediatley pulled out about 3 weeks ago. Never stopped working and had no issues since. I've tried diffferent cables and machines.
     
  8. Dan14 macrumors regular

    Joined:
    Aug 28, 2009
    #8
    Try another computer, I have this problem on my Mac but worked fine on my girlfriends. You have to completely remove iTunes, search on the Apple site how to fully remove it - it worked for me.
     
  9. nednarm macrumors 6502

    Joined:
    Apr 26, 2010
    Location:
    U.K
    #9
    This happens all the time on my iMac no matter what iDevice I try restoring it hangs at 60%, when I use my dads iMac however it works perfectly.

    I guess that if I reinstall iTunes it should fix the problem but I can't be bothered to test it out.
     
  10. skyfreedom macrumors member

    Joined:
    Sep 16, 2008
    #10
    This has happened to me many times on my Macbook Pro and my iMac, the firmware is installed correctly however the verification fails.

    After some research i got "RecBoot" http://www.sebby.net/443-recboot-final-release/, this app allows you to take your phone out of DFU mode and into DFU mode.

    After the itunes error shows up i quit itunes and run Recboot exit and the phone reboots and all is fine.

    Try it out.
     
  11. vingochr macrumors member

    Joined:
    Feb 21, 2011
    #11
    Same problem as all you guys. When the restore hung, I used RecBoot 2.2 (http://sebby.net/2011/02/02/recboot-2-2/) WITHOUT quitting iTunes. It said "Unknown Device Connected". I clicked enter recovery and the iTunes restore worked as per usual.
     
  12. vilim12 macrumors regular

    Joined:
    Feb 13, 2008
    #12
    I know its an old post but whatever, no one replied since this post. I tried what he said to do and it got me passed 60%, recboot said no device connected but i clicked enter recovery and it still went through.
     
  13. Matjoez macrumors newbie

    Joined:
    Dec 30, 2011
    #13
    I just registered to let you guys and other people like me in the future know that this method worked.

    I've always had problems restoring iphones on my mac pro 1,1, after using recboot to exit recovery mode during the restore hang, it kind of jumpstarted it again and continued on.

    Now I just have to try and get my backup on this 4s from my 3gs, that's where the trouble started 5 hour ago :s
     

Share This Page