iPhone 4 help needed.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by anthvale, Aug 17, 2012.

  1. anthvale macrumors newbie

    Joined:
    Jul 21, 2009
    #1
    So I recently replaced my power flex cable, headphone jack cable, and front screen on my iphone 4. I've taken it apart several times, but this time something is wrong.

    When replacing the headphone jack theres an antenna you fold down onto the headphone jack and screw in. That cable snapped. Replaceable?

    Also Something is glitchy I get a red circle with no number inside of it on my phone app. And it will let me dial, but when i hit call it won't register. When im in my favorites I can click on names of contacts but nothing happens.

    I tried cleaning the cable connecting areas with alcohol and no good.

    Hard reset, nothing...

    Now when I put my old power flex cable back in, it's still glitchy and I can't do a hard reset because the power button doesn't work.

    This is the third power flex cable I've orders, none have worked. Is it the logic board? or the cable?

    The old one always works but doesn't work. It isn't glitchy at all but the button itself doesnt work. But the newest one i've gotten the button actually works, but makes the phone glitchy.

    Now I've tried to go in a investigate again but broke the headphone jack cable so I need to order a new one, but until then...any ideas?

    Also when it was up and running (with the glitch) i had no service...Think the bottom antenna needs to be replaced? Or is it that antenna I broke that I stated above?

    Again I've taken this thing apart probably 20 times so things are getting weak I don't know if this is why things are breaking but I didnt really do much to the bottom antenna i hope it's that and not my logic board.

    Any ideas on all my problems haha?

    Anthony
     
  2. anthvale thread starter macrumors newbie

    Joined:
    Jul 21, 2009
  3. daudi macrumors member

    Joined:
    Jan 1, 2012
    #3
    thats quite a rape of an iphone 4 :p you can see ifixyouri guides on assembling iphone 4 different parts. those might help you out...

    or else take it to the apple store or some near by mobile shop and ask them to fix it for you. they will let u know the right error in the device.
     

Share This Page