iPhone 4 home button - miss fires

Discussion in 'iPhone' started by dand1996, Oct 10, 2010.

  1. dand1996 macrumors regular

    Joined:
    Jan 1, 2009
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A306 Safari/6531.22.7)

    Looking for some opinions. A couple times a day my iPhone 4 will not do anything when I hit the home button (it immediately works upon hitting again ) and will pull up multi tasking when I click the home button once.

    I am Jb on 4.0.1. The fact that this only happens a couple times a day, and not consistently leads me to believe it's amsoftware issue. Could it be activator? Any opinions?
     
  2. wirelessmacuser macrumors 68000

    wirelessmacuser

    Joined:
    Dec 20, 2009
    Location:
    Planet.Earth
    #2
    Stop by an Apple store & have it looked at. Sofware either works or it doesn't.
     
  3. jpw16 macrumors member

    jpw16

    Joined:
    Jun 12, 2010
    #3
    I have this same issue with my iPhone 4 too. It happens every day once or twice.
     
  4. dand1996 thread starter macrumors regular

    Joined:
    Jan 1, 2009
    #4
    Hardware typically either works or it doesn't. Its all or nothing.

    Software can be corky and present intermittent issues.
     
  5. aslucher macrumors member

    Joined:
    Mar 13, 2008
    #5
    You know I have been having the same problem and honestly its making me extremely angry. I have a launch device if it matters.

    I think it is software, only because with 4.0 came multitasking(nothing new i know just hang on) and with that came a reorganization of the home button's control. Aka they changed something and its not perfect, maybe there is a lag in a check to see what programs are running??? Idk just throwing crap out there..
     
  6. tangokim macrumors member

    Joined:
    Jun 23, 2010
    #6
    i have the same problem, jb at 4.0.1 and i though jb causing this, so i upgraded to 4.1 stock with the same problem. i took it to apple store and they took the back cover off and reinsert the ribbon(according to them,lol).they also told me my springboard crashed/corrupted and recommend restore.same issues after fresh restored, took it to apple and swap it out, new phone NO MORE issues with home button. The hardest part of this is duplicate the problem to those apple guys,they think im crazy and wasting their time.i hate going in there,they never believe you.
     
  7. draz macrumors 6502a

    Joined:
    Jun 20, 2010
    #7
    This only started happening after I jailbroke today via limera1n running iOS 4.1

    The home button worked perfectly fine before
     
  8. serialtoon macrumors 6502a

    serialtoon

    Joined:
    Jul 1, 2009
    Location:
    Long Beach
    #8
    Yea im having the same issue. Not a big deal to me but i see it as a software glitch than anything else. Anything that can keep me from having to visit the so called "Genius' " is ok with me.
     
  9. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #9
    So no one else thinks we need a JB section on the forums? Awesome.
     
  10. Fliesen macrumors 6502a

    Fliesen

    Joined:
    Mar 30, 2010
    Location:
    Austria
    #10
    hey, that actually happens to me too, very rarely though, and not at all reproduceable

    Trying to quit an app with a single homebutton tap, it opens up the multitasking bar.

    So, i suppose its a little software glitch, then
     
  11. jmmtn4aj macrumors member

    Joined:
    Feb 29, 2008
    Location:
    Singapore
    #11
    It's likely hardware. The button, despite it's simplicity, is ultimately a mechanical device. Like all mechanical devices it's prone to failure.
     

Share This Page