iPhone 4 JB + Unlock issues

Discussion in 'Jailbreaks and iOS Hacks' started by tanyeehou, Apr 26, 2011.

  1. tanyeehou macrumors newbie

    Joined:
    Sep 2, 2009
    #1
    Hi guys,

    I bought my phone from US via ebay, and I'm having some trouble unlocking it.

    The phone is currently on 4.3.2., IINM 4.3.2 (didn't check at that time, as I didn't think I'll be going through so much trouble) when I first got it. It is an AT&T unit, which means its GSM.

    Just running through some things and facts so maybe someone will spot something I did wrong.

    Anyway, I JB-ed it using iClarified's tutorial (http://tinyurl.com/3hb66tq) and later tried unlocking the phone using ultrasn0w, and later read about ultrasn0w fixer (http://tinyurl.com/3ul3j7n).

    Unfortunately I can't add the repository djayb6.com (since about 24 hours ago) even after multiple tries (Did not find repository). Tried other repositors like repo666.ultrasn0w and they worked. After reading this Lifehacker thread (http://lifehacker.com/#!5795242/sav...-losing-the-ability-to-jailbreak-your-idevice) I'm starting to think if djayb6.com has been down for the past 24hours I've been trying to unlock my phone? Edit: Found out that djayb6's repository is down as ultrasn0w 1.2.1 is not available anymore, what does this have to do with us 1.2.2 users?

    I was thinking of downgrading to 4.3.1 but I can't because I do not have the SHSH blobs (the phone either came with 4.3.2; or else I might have erased the blob with my jailbreak).

    I also have some problem understanding the baseband issue on whether should I upgrade them or not (as I've read many JB tutorials that state 'no baseband upgrades')

    Additional information: I live in Malaysia and would be using DiGi as my telco, in case any other Malaysians are reading this thread.

    I'm at the point where I wonder if bouncing my new iPhone off the wall would solve any of these issues, and I'm sure it'll be really thankful if anyone could give me a little tip on ways to save my phone from a premature death (not really, I'm just ranting)

    Thanks!
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You should have researched more before spending the money.
    You can't unlock just any baseband version. It has to be on 4.0.2 firmware or below, anything higher and the unlock is not available. And since yours came with 4.3.2 then you're out of luck. Go to settings, general, about and let us know thr modem firmware anyway. You can use one of those gevey turbo sim adapters though to unlock also.
     
  3. tanyeehou thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #3
    Yeah its abit of a bummed up situation :( Didn't really foresee this as its my first iPhone here, and all my friends didn't have any issues with jailbreaking/unlocking their iPhones (3g / 3gs etc).

    The modem firmware is 04.10.01. Is there a specific way to find out which number works for my particular telco?
     
  4. Sine Qua Non macrumors member

    Joined:
    Apr 4, 2011
    #4
    It's not your local telco that's the issue. It's the fact that there is no hack for that baseband version available that will allow you to unlock. For the iPhone 4, there is no unlock for anything higher than BB 01.59.00.

    edit: that is, no software unlock with something like ultrasn0w. You can look into a turbo sim like mentioned before in this thread for an unlock.
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
    You need one of these:
    http://obamapacman.com/2011/04/iphone-4-unlock-with-65-rebel-micro-sim-card/
     
  6. tanyeehou thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #6
    Thanks guys.

    I went ahead and got one and it works!

    The bad bit (sigh I'm having such bad luck) is that my primary sim doesn't seem to work in it so I'm still keeping my blackberry (sorry!!!) for now.
     

Share This Page