iPhone 4 keeps going into recovery mode and becomes a "brick"...

ZTuned

macrumors member
Original poster
Jun 7, 2007
40
0
Well this is the third or fourth time it's happened with my iPhone 4. I reached for my iPhone to unlock it only to find that the screen won't turn on and the menu/power buttons are unresponsive. At this point, my iPhone 4 refuses to do anything -- it won't shut down or reboot, just a black screen. It won't turn on and it won't charge even when plugged into the wall charger. I can't even force to reset it by holding the power/home button.

When I plug it into my MBP, I need to launch iTunes manually and then I get this message:



If I get lucky, holding down the home and power button will turn on the phone if it's plugged into the laptop.

This time, I can't get it to turn on and the phone is basically bricked. I don't want to restore the phone as I'll lose a few apps.

Anyone experience this or have a solution?
 

ichris14x

macrumors member
Aug 5, 2010
39
0
Isn't there way to unbrick? Like say, connect to iTunes, hold home and power, after, you release power and continue to hold home? Something like that, I bricked it once and I used a method similar to this one to unbrick. Hope it helps
 

ZTuned

macrumors member
Original poster
Jun 7, 2007
40
0
Got it to turn back on after plugging and unplugging the iPhone into the USB port on the MBP and holding the home + power key. I guess it was a stroke of luck that it worked once out of the 10+ times I tried.

I'm still curious why this keeps happening. I'm wondering if I should do a full restore and then transfer everything back.
 

dockingbay94

macrumors regular
Jul 29, 2010
101
0
Perform a DFU restore on the iPhone. Open iTunes and plug it into the computer and hold the lock+home button down until it powers off. Continue holding for 8 seconds and then let go of the lock button and continue holding the home button until it appears in iTunes. The display on the iPhone should still be black at this point, if you have anything else on the display try again.

I would then recommend not restoring from your backup and instead setting up as a new iPhone incase you have corruption in your backup.
 

dooger123

macrumors newbie
Jun 23, 2010
16
0
Download FirmwareUmbrella, the same program that you use to backup your SHSH blobs.

Open up the program, and then plug in your iPhone. On the top right corner, there should be a button that says- "kick device out of recovery"

viola. That should work. Same thing happened to me, and it worked like a charm.
 

ZTuned

macrumors member
Original poster
Jun 7, 2007
40
0
Would like to avoid jailbreaking for now, though I'm curious of the root of the problem. Will most likely just do a clean restore if it happens again.
 

imacdaddy

macrumors 6502a
Feb 2, 2006
661
0
i had this problem with my iPad. I even created a new user on my Mac and had it connect to iTunes to restore but to no avail. (Apparently this may work for many)

I had the iPad exchanged for a new one at the Apple Store.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.