iPhone 4 Mailbox problem????

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Prissy, Jul 1, 2010.

  1. Prissy macrumors 6502

    Joined:
    May 7, 2009
    #1
    I am pretty frustrated now... My mailbox is acting up weird:
    It keeps on recieving mails w/o contents, sender, and it would show some weird sent date (ie: 12/31/00). And it will not let me delete it. But when I go to "All Mail" then come back to Inbox, those unknown mails would disappear...
    Does this happen to you guys?
     
  2. kevwright macrumors member

    Joined:
    Nov 20, 2007
    #2
    If its Exchange, this will help. If not, sorry, not sure.

    Kev
     
  3. Prissy thread starter macrumors 6502

    Joined:
    May 7, 2009
    #3
    what do you mean by exchange?
     
  4. Chult86 macrumors newbie

    Joined:
    Jun 24, 2010
    #4
    Ya I'm having the same problem. It's synced with my gmail account, and has been acting funny ever since i got a 4.

    No sender/no content emails, saying I have new mail when I definitely don't. Kinda screwy so far.

    Any fixes?
     
  5. Gin Gin macrumors regular

    Gin Gin

    Joined:
    Jun 22, 2009
    #5
    There have been a few threads about this. It's not the iPhone 4, it's iOS4. Happened to me on my 3GS since upgrading the OS. Shutting down the phone and then restarting it seemed to fix it for me, at least for now.
     
  6. toshmac macrumors member

    toshmac

    Joined:
    Jun 16, 2010
    Location:
    Philadelphia metro
    #6
    Yea, so I had a problem too when I upgraded to iOS4 on my 3GS and it persisted once I got the iPhone4/iOS4.

    I deleted all my e-mail accounts through Settings on the iPhone and then added a Microsoft Exchange account for Gmail as shown here:
    http://www.google.com/support/mobile/bin/answer.py?answer=138740&topic=14252

    I sync my mail, contacts and calender and it's worked perfectly since.

    Good luck..
     

Share This Page