iPhone 4 - music playback briefly cuts out

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Chic0, Jun 29, 2010.

  1. Chic0 macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    UK
    #1
    Anyone else experiencing this issue. When playing music and ipod player open, when I want to unlock phone and go back to homescreen, the sound briefly cuts out and goes silent for split second.

    I can reproduce this everytime. Just wondered whether this is standard on iphone 4/Ios4.
    This never used to happen on my iphone 3G.

    Steps
    • Play some music using ipod player
    • with ipod player still open, press power botton to lock phone
    • press home button then slide to unlock (sounds briefly cuts out)
    • with ipod player open, press home button (sounds briefly cuts out)
    Anyone else getting this?


    cheers
     
  2. extasis macrumors newbie

    Joined:
    Aug 23, 2010
    #2
    Hi there,

    Yes, I am having the same problem. It is very annoying as there is no reason for the music to skip (even momentarily) when locking/unlocking or pressing the home button.

    I set up my iphone 4 as a new phone, did not restore from back up.

    If anyone has any ideas or fixes for this problem they would be greatly appreciated. Would like to avoid restoring if at all possible...

    Thanks
     
  3. extasis macrumors newbie

    Joined:
    Aug 23, 2010
    #3
    Update: not sure about others, but for me it doesn't happen all the time. If I am able to produce the "silent gap" the first time by either simply pressing the home button while playing music, or locking / unlocking the phone, upon 2nd or 3rd try the music may not skip.

    Either way, it's definitely a bug of some sort, as if it is a feature, it's broken (and sucks!).

    Hopefully someone else notices this issue. I have tried searching for it online but this is the only relevant thread I can find. On iOS 4.0.2.
     
  4. spoem macrumors newbie

    Joined:
    Jun 16, 2006
    #4
    Hi,

    I'm experiencing the same issue. In my case, it seems to be related to the amount or complexity of the album art. I've only tested with podcasts, but I've found that podcasts that have no album art, or a single image do not jump when locking/unlocking.

    Would you be able to try with music with no art?

    Do you have lots of album art?

    I've raised a bug report with apple #8408462.
     
  5. extasis macrumors newbie

    Joined:
    Aug 23, 2010
    #5
    Agree!

    Thanks for posting this. I realize that it only happens with the podcast that I listen to (538 Dance Department), which has plenty of album art that changes as the songs change throughout the ~1hr podcast.

    With any other songs with or without album art, I do not have this problem.

    So it does seem to be isolated to music (podcasts) with lots of album art.

    Is there any way I can add support to the bug report you submitted? Hope this issue gets addressed soon, as it is annoying.
     
  6. extasis macrumors newbie

    Joined:
    Aug 23, 2010

Share This Page