Iphone 4 No service problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by applemessiah, Jul 13, 2011.

  1. applemessiah macrumors member

    Joined:
    Jul 8, 2011
    #1
    i have an iphone 4 i just restored. 4.3.3 firmware. I pop in a sim and it picks up signal but after a minute or two it slowly starts dropping bars until it says searching then eventually no service. What could be causing this problem?
     
  2. applemessiah thread starter macrumors member

    Joined:
    Jul 8, 2011
    #2
    Problem Solved

    Not to revive old post but i got my phone to work. I was having signal issues and even after restoring it was still not working. Ended up getting frustrated and just dissambeled the whole phone down to the LCD (since i did that, i also installed the earpiece mesh). I then assembled the phone slowly, making sure all my screws were tight and all my connections were good. Popped on back cover, popped in Sim and works great! Hope this helps somebody.
     
  3. g12007 macrumors newbie

    Joined:
    Jul 13, 2011
    #3
    so what do you think was the "root problem" with your device?
    i kno the mesh screen couldnt be it right :confused:
     

Share This Page