iPhone 4 - no vibration or sound for texts

Discussion in 'iPhone Tips, Help and Troubleshooting' started by NominNomin, Nov 18, 2012.

  1. NominNomin, Nov 18, 2012
    Last edited: Nov 18, 2012

    NominNomin macrumors newbie

    Joined:
    Nov 18, 2012
    #1
    Hi,

    Recently my phone stopped vibrating or playing my text tone when I get a text. The phone both vibrates and makes sound when I receive a call however.

    The device is jailbroken and I have also tried biteSMS but this did not change the situation. I noticed that toggling the mute switch on/off no longer causes the little vibration that it used to, and when the phone is off mute there is no vibration or clicking when typing, or any click when locking. Vibration, lock sounds and keyboard clicks are all turned on in sounds in the settings. Toggling 'vibrate' under 'silent' (in sounds in the settings) off and on makes the device vibrate, but it still won't vibrate when recieving a text.

    Has anyone else experienced this? Any help or suggestions would be really appreciated
    Thanks
     
  2. texasmccoy macrumors member

    texasmccoy

    Joined:
    Sep 24, 2010
    Location:
    Northern California
    #2
    Similar issue

    I also have an iPhone 4, running iOS 6.0.1. Mine isn't jailbroken however. But it has some weird things going on with messages. First of all, texts and imessages no longer make that "woosh" sound when a message is sent or received, even though I don't have the sound muted or the Do Not Disturb thing activated. The tone indicating a text has arrived (when the conversation isn't open already) works fine though. Secondly I've noticed that in the notification center for my phone, "messages" is listed twice. Both list items are similar but not identical. One has a setting for sounds to be on or off, and the other doesn't. I don't know if this is causing a conflict not allowing the sounds to happen or what. Every time I update my iOS I end up regretting it for some reason :mad:
     
  3. JamesWilliams12 macrumors member

    Joined:
    Nov 13, 2012
    #3
    First check on the sounds if the vibrations is on, after go on notification center and set messages on, click on messages and check vibration on.

    Hope that you're gonna resolve a issue
     
  4. NominNomin thread starter macrumors newbie

    Joined:
    Nov 18, 2012
    #4
    Vibration is on in sounds, messages are on in the notification centre. But in my notification centre, for messages there is no option to set sounds or vibration on. I notice that other apps have a toggle called 'sound' underneath the 'badge app icon' switch. This is simply not there under messages.
    Could the absence of this switch for messages be the cause of the problem?
    Thanks
     

Share This Page