iPhone 4 no wifi and screen flickering?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by GelleCC, Feb 29, 2012.

  1. GelleCC, Feb 29, 2012
    Last edited: Feb 29, 2012

    GelleCC macrumors regular

    GelleCC

    Joined:
    Jul 13, 2008
    Location:
    Seattle, WA
    #1
    EDIT: Just made a vimeo account and it looks like the videos need to convert before they work. Here's the link but it said about 30 min (at 4:15 Pacific time) http://vimeo.com/37703719

    I'll be posting a link to three (short - 20 second) videos of what the screen looks like and you should also be able to see the grey "no wifi" - ignore the audio, I was watching "A History of Violence" when I took the video and realized it might have dropped a couple F-Bombs.

    Here's the problem. I bought the phone broken to fix and give as a gift. I thought it just needed a new battery since it would only turn on when plugged in (it also gets really hot when charging). I replaced the battery and noticed the phone was greyed out on the "WiFi" under settings.

    I did do some googling prior to coming here and most places said restore the phone - (currently on 5.0.1). So I restored a couple times and even tried jailbreaking. Still, no wifi. So I replaced the wifi antenna. Still nothing. Then I replaced the GSM antenna (I read that it might have something to do with that as well). Still nothing. Now I'm noticing that the screen flickers and today it flickered like crazy and went black (it was still turned on - a "lit up" black) just no picture. The picture was there then flashed and faded to black. Then the picture came back about 20 seconds later.

    TL;DR Like I said, I've replaced the battery, wifi antenna, and GSM antenna. The phone still gets really hot when charging (around the middle section of the logic board). The screen is acting funny. I've restored several times and I've tried jailbreaking. Currently on (jailbroken) 5.0.1.

    Thanks in advance!
     
  2. GelleCC thread starter macrumors regular

    GelleCC

    Joined:
    Jul 13, 2008
    Location:
    Seattle, WA
    #2
    Just for some updates, I never figured out what the problem was. Ended up just selling the phone for parts.
     

Share This Page