iPhone 4 "not eligible" for 4.3.2 update?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by CoffeeMonkey, Apr 18, 2011.

  1. CoffeeMonkey macrumors regular

    Joined:
    Feb 23, 2003
    #1
    I just bought a new iPhone 4, running iOS 4.2.1 right out of the box. Not jailbroken. Using iTunes 10.2.2 (12) on a 2009 MacPro on whatever the most recent Snow Leopard build is.

    When I plugged it in to my mac for the first time, it prompted me to update to 4.3.2.

    I've tried upgrading to 4.3.2 several times. Each time it tells me that the device isn't eligible for that upgrade. I went into /Library and deleted all of the previous iPhone updates, downloaded a fresh 4.3.2, same problem.

    Restarted the system, same problem.
    Tried different USB cable in different USB port, same problem.

    Re-downloaded the software, and got a (9006) error message partway through.

    Tried again, got the whole file downloaded, iTunes extracted it, and during the "verifying with Apple" stage I got the error message "This device isn't eligible for the requested build.

    Any ideas? I'm really getting sick of this process.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Check your hosts file for any entries to apple.com and remove them. (Use Google to find the location of the hosts file and how to edit it.)
     
  3. CoffeeMonkey thread starter macrumors regular

    Joined:
    Feb 23, 2003
  4. dave420 macrumors 65816

    Joined:
    Jun 15, 2010
    #4
    I'll echo that I'm getting sick of this process. I am getting the same error even after editing my hosts file. I've had several failed attempts in the last few days.
     

Share This Page