iphone 4 not playing music through dock connector?

Discussion in 'iPhone' started by RobbySkateboard, May 19, 2014.

  1. RobbySkateboard macrumors regular

    Joined:
    Jul 3, 2010
    #1
    I have an in dash navigation system in my car (Pioneer Avic 940bt if it's helpful) and I used to be able to plug in my iphone 4 and play music from it, but for whatever reason I haven't been able to for the past 6-9months (I've just been using my iphone 5s and bluetooth audio) but I'd like to be able to navigate through music easier than reaching in my pocket so I'm trying to figure it out. I can plug it in, it'll be connected and I can search through my music via the dash screen and click to play a song and it'll start to play it but without any sound. It will let me know how far into the song I am etc. but nothing actually comes out of the speakers.
     
  2. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #2
    So it's your iPhone 4 that stopped playing or it stopped when you moved from 4 to 5S?
    What cable are you using?
     
  3. RobbySkateboard thread starter macrumors regular

    Joined:
    Jul 3, 2010
    #3
    I want to use the i4 as my iPod for my car and I'm using the same cable I've always used in the past, a normal 30 pin that plugs into the in dash systems USB
     
  4. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #4
    Weird.
    The reviews that I read said it required a special cable with a separate 3.5mm plug.
    [​IMG]

    I was wondering if your cable may have gone bad.
    Did you upgrade your iPhone 4 to iOS 7?
    That's the other thing I noticed -- the spec sheet from Pioneer specifically mentions iOS 6 compatibility. Nothing in there about iOS 7.
     
  5. RobbySkateboard thread starter macrumors regular

    Joined:
    Jul 3, 2010
    #5
    I am on ios 7 and that's actually exactly when it stopped working. Is there a way to downgrade it to 6.x?
     

Share This Page