iPhone 4 not reading under Devices in iTunes (Windows 7 64bit)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Diventia, Jan 27, 2011.

  1. Diventia macrumors newbie

    Jan 27, 2011
    I purchased an iPhone 4 less than a week ago, and after a small freezing scare today, I feel I may have jumped the gun and acted too hastily by placing the phone in DFU mode.
    After trying to restore it to factory settings, the iPhone wouldn't read in iTunes. For a while there was an issue with the driver, and it was reading only as a digital camera (under Portable Devices in the Device Manager) but after I corrected that issue, I thought everything would be okay. Unfortunately, the phone is still not reading under Devices in iTunes. When I connect the phone to my PC, iTunes staggers and stops responding for upwards of 60 seconds, but after that period it's as if nothing has happened.

    I have tried disabling any program/process that could be interfering with it, I've deleted and reinstalled iTunes multiple times. I've followed the standard troubleshooting page on the Apple website to the T. Any help or suggestions would be more than appreciated; I've been hitting my face against the desk for about seven straight hours trying to resolve this.

    The phone itself is stuck on the connect to iTunes screen which allows you access to the slide bar in order to make emergency calls.

    Thanks in advance <3

    note: I apologise for making a new thread about this. I've been searching for fixes on multiple websites for hours and nothing on here, or anywhere else, has gotten me anywhere.

Share This Page