Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iPhone 4 not sending email WITH attachments

xta

macrumors newbie
Original poster
Jan 31, 2011
9
0
My phone will send all email and receive all email perfectly fine except when I have an attachment.

Any ideas on why this is happening?

I use Gmail... All my emails with attachments are sitting in my outbox, when I click the outbox the line scrolls across the bottom fast saying sending 5 and completes but they just sit there.

Any help greatly appreciated!
 

xta

macrumors newbie
Original poster
Jan 31, 2011
9
0
that's not it because it's happening when sending only one photo taken with hipstamatic which is less than 1MB.... thanks anyways.

anyone else?
 
Comment

JamesMB

macrumors 68000
Jan 2, 2011
1,745
107
Texas
My phone will send all email and receive all email perfectly fine except when I have an attachment.

Any ideas on why this is happening?

I use Gmail... All my emails with attachments are sitting in my outbox, when I click the outbox the line scrolls across the bottom fast saying sending 5 and completes but they just sit there.

Any help greatly appreciated!
Do you have Gmail set up as POP or Imap? I have had trouble with Gmail and attachments, when using POP.
 
Comment

xta

macrumors newbie
Original poster
Jan 31, 2011
9
0
using IMAP. also, the exact error message is:

"Cannot Send Mail. A copy has been placed in your outbox. the recipient "[email address]" was rejected by the server."

I have confirmed I am using the correct email address and it is happening for all contacts I have tried sending to and this includes email addresses I can successfully email WITHOUT sending attachments.
 
Comment

JamesMB

macrumors 68000
Jan 2, 2011
1,745
107
Texas
Can you verify that your outgoing mail server is "smtp.gmail.com", and that the server is using port 587?
 
Comment

xta

macrumors newbie
Original poster
Jan 31, 2011
9
0
yes, SMTP is smtp.gmail.com
port was 993, but changed to 587 as you suggest. problem remains.

Also, worth noting that until last week I've had no problems sending emails with attachments before.
 
Comment

xta

macrumors newbie
Original poster
Jan 31, 2011
9
0
yes, you're right. Ok, just changed the incoming back to 587 and confirmed that the outgoing was and is at 993. problem still there...

argh!
 
Comment

JamesMB

macrumors 68000
Jan 2, 2011
1,745
107
Texas
yes, you're right. Ok, just changed the incoming back to 587 and confirmed that the outgoing was and is at 993. problem still there...

argh!
That's still not right. The incoming should be 993, the outgoing should be 587.
 
Comment

xta

macrumors newbie
Original poster
Jan 31, 2011
9
0
no, sorry, i have had it exactly as you said... just typed it opposite in my reply. problem still unsolved!
 
Comment

JamesMB

macrumors 68000
Jan 2, 2011
1,745
107
Texas
no, sorry, i have had it exactly as you said... just typed it opposite in my reply. problem still unsolved!
I thought that might be the case, just wanted to make sure.

If you have other mail accounts, on your phone, you might check to make sure that Gmail is in fact using the, outgoing mail server "smtp.gmail.com" and it is set to ON
 
Last edited:
Comment

xta

macrumors newbie
Original poster
Jan 31, 2011
9
0
yes, it's set to ON. ugh! anyone else have any ideas?? i don't understand why this has happened all of a sudden!
 
Comment

JamesMB

macrumors 68000
Jan 2, 2011
1,745
107
Texas
Have you tried opening gmail through safari, and trying to send attachments there?
That should prove whether the trouble is with Gmail itself or the phone.
 
Comment

xta

macrumors newbie
Original poster
Jan 31, 2011
9
0
wouldn't that mean I wouldn't be able to send attachments from my laptop on Gmail as well? also, there isn't a way of sending attachments from gmail on safari via iphone... that i can see anyway...
 
Comment

JamesMB

macrumors 68000
Jan 2, 2011
1,745
107
Texas
wouldn't that mean I wouldn't be able to send attachments from my laptop on Gmail as well? also, there isn't a way of sending attachments from gmail on safari via iphone... that i can see anyway...
Doh! Yeah you are right, about the attachments through Safari. Have you tried on your laptop?
 
Comment

JamesMB

macrumors 68000
Jan 2, 2011
1,745
107
Texas
I really don't think that it would do any good but if you haven't already done it, you might delete that Gmail account and reinstall it. Simple to do, and sure can't hurt.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.