iPhone 4 not turning on after jog.

Discussion in 'iPhone' started by Fisticuffs2065, Jul 26, 2010.

  1. Fisticuffs2065 macrumors member

    Joined:
    Jun 20, 2010
    #1
    So today I was excited to try out the new Nike+ app on the iPhone. I did my jog, took off the arm band, to which my iPhone 4 was in, and took a shower. After I came out of the shower, I took my iPhone 4 out of the arm band, and to my surprise, it would not turn on.

    I tried connect it to a charger etc, still no avail. I opened up the iPhone on the back to see if the moisture sensors were triggered or not, and again I was surprised. The moisture sensors that are supposed to be in there are not! :confused:

    Anyways, another trip to the apple store -_-

    To give this thread a point, any clue on to what happened???
     
  2. sic2five macrumors member

    Joined:
    Jul 22, 2010
    #2
    U tried resetting? hold power + home button for 5-10 seconds.
     
  3. hryan4740 macrumors regular

    hryan4740

    Joined:
    Jun 8, 2010
    Location:
    NoVA
    #3
    Probably a stupid question, but did the battery die? If so, it might take a little charging before it will come back on. Also, I'd try a hard reset before schlepping to an Apple store. But yeah, if it's not battery, that's really weird.
     
  4. anonymous guy macrumors 6502

    Joined:
    Mar 18, 2010
    #4
    Also, check the water sensors within the headphone jack and the bottom charging port. If they were exposed to water, they will turn orange/red.

    If the sensors weren't tripped (are white), then you might try getting a replacement at the Apple Store.
     
  5. Alphaspida macrumors member

    Joined:
    Jun 14, 2009
    #5
    Probably was too much force moving around inside of the iPhone while jogging.


    Probably messed up some internal components. Just my theory though
     
  6. iSaxon macrumors 6502a

    iSaxon

    Joined:
    Jun 19, 2010
    Location:
    Pittsburgh, PA
    #6
    Nothing should get messed up from jogging. It's a mobile phone. Nike+ was designed for Apple and should work fine with jogging.
     
  7. Stein357 macrumors 6502

    Joined:
    Jun 18, 2010
    Location:
    Rip City
  8. himni macrumors regular

    Joined:
    Sep 24, 2009
    #8
    My sisters 3GS has done this a couple times for some reason. What I did to fix it was hold in the home and power button and it powered on.
     

Share This Page