iPhone 4 Notification Sound Bug? Do you have this bug?

MicroApple

macrumors regular
Original poster
Jul 26, 2010
154
0
Sometimes randomly after unlocking my phone or turning it on, (specifically a couple seconds maybe 4, of looking at the Home screen) I hear a noise. I'm not sure if it vibrates or not I'll check next time. But it seems to be some sort of notification that happened. Now I have no apps running but I get this beep sound. I checked text messages, emails, push notifications, battery, coverage yet its not one of those. Maybe its WiFi. But for some reason I get this random beep of the phone trying to notify me of something but it never shows up on the screen. Sometimes after locking my phone (screen being black) it does the noise.

Anybody have any clue to what sort of notification this is?
 

studio¹³¹

macrumors 6502
Jul 31, 2009
343
182
when i open mail, and it plays the notification sound -- i hear an 'air' sound that plays a split second longer than the notification. i think this happened w/ the 3gs too -- but this seems to be a lot more noticeable...
 

MicroApple

macrumors regular
Original poster
Jul 26, 2010
154
0
So it is the mail app causing it? I haven't recieved any new emails so I'm not sure about it. It's happening on the home screen without any apps open. And nothing appearing on screen.
 

SAD*FACED*CLOWN

macrumors 65816
Apr 5, 2010
1,342
1
Houston, TX
I've been getting "ghost" email notifications or the email notification arrives after I've already seen, read, and deleted the new email...I've noticed this for a while now, since the update before last I believe
 

MicroApple

macrumors regular
Original poster
Jul 26, 2010
154
0
I've been getting "ghost" email notifications or the email notification arrives after I've already seen, read, and deleted the new email...I've noticed this for a while now, since the update before last I believe
In that case it might be the mail app, lets see if others have this problem.
 

mockbrown

macrumors newbie
Feb 26, 2008
10
0
Berlin
I have got this, or a similar, bug after upgrading to iOS 5.0.1 on an iPhone 4. I get the normal notification sound, but the screen does not light up, and there is no notification to be found... Strange.