Iphone 4 - O2 - UK - 'Could not activate cellular data network'?

Discussion in 'iPhone' started by Reser, Jun 30, 2010.

  1. Reser macrumors 6502

    Joined:
    Apr 14, 2010
    #1
    Ok,

    Today I am sitting at work with phone on desk, and suddenly i notice a message popup on screen ' could not acitvate cellular data network' . I look at top of screen and see it still has 5 bars and 3G so figure its nothing , ok the error and continue with my work.

    Later I try to use the internet and even with 5 bars and 3G at top of screen it pops up again and I cannot do anything internet wise on phone.

    I have tried turning phone on and off twice, tried resetting network settings twice, checked data settings and they are same as they have always been.

    What on earth is going on? How do I fix this?
     
  2. Macjames macrumors 6502a

    Joined:
    Dec 12, 2007
    Location:
    Yorkshire, England
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A293 Safari/6531.22.7)

    I'm having a similar issue, but on vodafone, I got to work and noticed full 3G bars (nothing unusual) and then went to check my email and nothing, same error message appeared. I turn 3G off in the settings and find my data still works on edge, at lunchtime I tested the phone outside and my 3G worked again! Ok I thought it must have been something temporary. I got back to work to find the same issue, 4-5 bars of 3G yet it will not work!
     

Share This Page