iPhone 4 on 4.2.1 Messaging issues?!?

Discussion in 'iPhone' started by Thinkgreen216, Mar 6, 2011.

  1. Thinkgreen216 macrumors newbie

    Joined:
    Jan 6, 2011
    #1
    So I finally broke down and re-jail broke my iPhone 4 to 4.2.1 and Im getting things back in order except for there's this one issue I cant find a fix for. It seems whenever I receive text messages the only thing my phone will do is vibrate. I've done the obvious things such as check my settings (ringer and vib) and I've even tried changing messaging alert tones as well. When Im in the settings changing the tones I can hear the sound just fine.

    I've uninstalled applications that I thought might be conflicting (Lock screen, Notifier) and its still giving me grief. The only other thing that could possibly be giving me issues would be the T-mobile MMS fix thats available on the LEI repository but without that patch I couldn't send or receive MMS.

    Its crazy because all of these things listed above worked great on my phone when I was on 4.0.1?

    Any help or suggestions would be greatly appreciated.
     
  2. Thinkgreen216 thread starter macrumors newbie

    Joined:
    Jan 6, 2011
    #2
    Im going crazy!

    Okay, here's a new discovery but not a solution to my problem. Im testing my phone by using my wifes phone to send myself text messages and this is what I discovered.

    If I go into her contact information and I delegate a custom messaging tone to her contact and then send myself a message it will work but texts from everyone else just vibrate.

    WTF?
     
  3. Thinkgreen216 thread starter macrumors newbie

    Joined:
    Jan 6, 2011
    #3
    no one else has this problem?

    So I discovered all of my new messaging ring tones that came with the 4.2.1 update will be audible when I receive new text messages but if I select any of my original message tones (the ones that all the other iphones have by default except iP4) it will only vibrate.

    This is nuts!
     

Share This Page