iphone 4 on recovery mode

Discussion in 'iPhone Tips, Help and Troubleshooting' started by npm1867, Nov 26, 2013.

  1. npm1867 macrumors newbie

    Joined:
    Nov 26, 2013
    #1
    hi everyone..just dropped my iphone 4 in the sink. i dried it up and brought it to my technician...he tried to dry all the parts inside the phone and turned it on...at first it was fine...everything worked as usual and suddenly the battery just died...so we replaced the battery with a new one and now..when u turn it on..the apple logo would come up and after 30 seconds or so it would go to recovery mode...can anyone please help me with this and is there anybody there who can actually say my phone will be back and running again...
    :confused:
     
  2. npm1867 thread starter macrumors newbie

    Joined:
    Nov 26, 2013
    #2
    version issue on iphone

    hi again...i just want to continue on my last post here...so now, the problem is the version of my phone which is 4.3.3..yes it is obsolete and since my phone is stuck in recovery mode..the technician couldnt restore it because they dont have the program anymore for 4.3.3!! and thats really bad news for me...the only option he gave me is to replace the motherboard which obviously is very scarce here. the other option is he can make my iphone work but...not as a phone but as an ipod!!!! hahahaha..silly!!! so now my problem goes to finding a replacement for my motherboard..can anyone suggest where i can find one? thanks a lot
     
  3. blueroom, Nov 28, 2013
    Last edited: Nov 28, 2013

    blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #3
    Which iPhone is it? A 3G? The 3G's last iOS was 4.2.1 not sure what 4.3.3 is.

    Just let iTunes upgrade to whatever it thinks your iPhone needs.

    Ahh your original post just showed up. The only iOS Apple is signing for the iPhone 4 is 7.x
    Since you drowned your iPhone (this is more often than not fatal to the iPhone's electronics) your best bet might be a OoW replacement from Apple.
     
  4. grazmix macrumors newbie

    Joined:
    Nov 28, 2013
    #4
    macbook pro & iphone

    Hi im new to this sorry not sure how to post properly, my problem is when i connect my 4s to my mac it says it don't recognise my 4s anyone got any ideas thanks
     

Share This Page