Iphone 4 only boots with charger (no wifi bluetooth or gps)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by DrunkenNinja, Sep 16, 2011.

  1. DrunkenNinja macrumors newbie

    Joined:
    Sep 16, 2011
    #1
    Today I see my Iphone 4 is literally dead, no buttons or functions work at all (No power).

    If conected to the P.C. I get an apple logo boot loop (apple logo appears for 10 seconds then screen goes black) no battery icon or sound is present either.

    O.K. if the phone is connected to the wall socket again there is no battery icon or sound, but the phone will boot but very, very slowly, battery level shows the A/C indicator, 100% and green, the phone is not in safe mode but there is no network wifi bluetooth or gps functional, these options are greyed out on the settings, after approximately 5 minutes the phone automatically dies again.

    I have seen simular problems on this forum and have done a lot of reading here before posting, this is what I have done so far, I can get the phone in DFU mode with I-tunes and have tried to restore but receive a 1611 error, tried cleaning connectors with a q tip from the outside, tried numerous variations to boot the phone including connecting to laptop from boot.

    I have ordered a new battery and pentalobe screwdriver so I can check the connectors and try a new battery, the phone has never been dropped and is in one of those bulky otterbox defender cases permanatly.

    I tried to search the symptoms of a dead iphone 4 battery but came up with nothing, What happens to an I-phone when the battery dies? If the battery and hardware review does not work I will be forced to give a jailbreak with Redsnow a shot.

    Please help, I am sure someone has some useful info on this.
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    If it's under warranty make an Apple Store appointment. Was it jailbroken?
     
  3. DrunkenNinja thread starter macrumors newbie

    Joined:
    Sep 16, 2011
    #3
    I bought it from an international seller (U.S.) 6 months ago, so I guess the warrenty is not valid anymore, plus there are no apple shops in Cyprus.

    Yes the phone is jailbroken.
     
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
  5. DrunkenNinja thread starter macrumors newbie

    Joined:
    Sep 16, 2011
    #5
    Many thanks for the replys, unfortunatly the link above doesn't say anything regular folk don't already know, and they call themselves experts :p

    I'm looking for the symptoms, if my phone will boot sporadically with a charger but remains dead when not connected to the wall charger, it's logical to look at the battery as the culprit.

    What I really want to know is how the phone functions with a dead battery when its plugged into the charger, does it diable wifi? will it show 100% charge due to it thinking no battery is present? This is the info I can't find on the net, but hopefully it will be here soon :)
     
  6. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #6
    No It Shouldn't

    Nothing should be disabled if its plugged into the charger unless you set it aircraft mode, or disabled wifi yourself. Thats why I have my doubts about it being a battery issue.
     
  7. DrunkenNinja thread starter macrumors newbie

    Joined:
    Sep 16, 2011
    #7
    Thats interesting, and if that is the case there would appear to be some other kind of damage to the phone, maybe something else power related.

    I will have to wait a week or so till I get the new battery and run some test, I will of course report back with my findings, in the mean time if anyone has experienced this problem please share your experiences.
     
  8. Itodz macrumors newbie

    Joined:
    Sep 28, 2011
    #8
    Have the same problem.
    iPhone 4 32GB white, don't power up with battery only when connected to a wall charger it power up into activation mode ( all the buttons work ) but when i disconnect the charger the iPhone turn off immediately.

    Tried to replace the battery and complete assembly, tried cleaning the board but noting work, still same problem.

    It's a hardware problem but i don't know what component it is...
     
  9. DrunkenNinja thread starter macrumors newbie

    Joined:
    Sep 16, 2011
    #9
    I fixed mine, but didn't get much help on this site though, gotta say I was dissappointed with the responses here all the signs were that it was a software problem but I guess it's easier to tell someone it's a hardware problem.

    I bought a new battery and it did not fix my problem, anyway here is the solution.

    First put the phone in DFU mode and run tiny umbrella, you will need your SHSH blobs for the firmware you want to restore, if they don't show up in the tiny umbrella interface get them with the program Faith now.

    Now the next step to download the firmware you want to restore and stick it on your desktop, now you are ready to do a custom restore in itunes.

    Run tiny umbrella and start the TSS server, Now in i-tunes hold Shift + click Restore to locate the firmware you stred on your desktop.

    Your iphone will begin to restore and complete most of the process (60%) and itunes will either throw and error at you or simply stop restoring

    Now here is the magic.

    Use redsn0w to jailbreak you device using the firmware you saved on the desktop

    Your phone will get stuck at "Installing activation bundles"

    Let it sit until a small translucent spinner like the loading sinner pops up (should take a few minutes)

    Reboot your device by holding the power and home button

    You phone will now enter emergancy mode and want to connect to itunes, if you are on AT&T you can just activate it and jailbreak after doing so

    For those without a legit SIM:

    Fire up redsn0w again and rejailbreak

    This time it will load all the way and actually take you to the homescreen

    add the repo.bingner.com/ source

    Install SAM

    Open up SAM and revert your phone to lockdown status

    Plug it into iTunes and let itunes restore from your back up

    I hope this help you guys.
     
  10. ravio1506 macrumors newbie

    Joined:
    Dec 25, 2011
    #10
    Even I'm facing the same problem with my iphone 3gs 32GB. It was recently gifted to me and was sent by courrier. When i received the courrier, the phone showed the same symptoms as mentioned in this thread. I couldnt fighure out what caused the problem. when it was sent in the courrier it was in perfect condition.

    I hope the soultion mentioned by "DrunkenNinja" also works with my phone.
    I spent several hour hours tying to find a solution on many websites, but i realized that this was not a common problem with iphone and hence couldnt come up with anything worth while.

    For now i'll try out the solution mentioned here n update you guys.

    ps: I feel quite relived to know that its not a hardware problem as my iphone is not under warranty period :)
     
  11. neologsin macrumors newbie

    Joined:
    Dec 28, 2011
    #11
    Wouldn't it upgrade the based of iPhone 4 if try to restore from the stock firmware downloaded.


    Secondly, redsn0w does not preserve baseband after the jailbreak...right?
    So for those running carriers other than AT&T, this process should do the job...right?

    BTW: it was good to see your post. Encouraging, as I have the exact same issue you mentioned in the first post. Nonetheless when I try to restore, iTunes does give me ERROR:1611, which according to therir support article may be an indication of hardware error http://support.apple.com/kb/TS3694#error1611
     
  12. Pr8ik macrumors newbie

    Joined:
    Feb 23, 2013
    #12
    Hello DrunkenNinja, I am having the same problem with my iPhone 4 32 GB, I want to try your solution to the problem but my basic question is how did you restore your phone when it doesn't even start, and because of which it does not show up in itunes. It keeps on restarting every 10 seconds with apple boot logo when connected via USB....and it starts for 5 min when connected to the mains supply. Please help me with this.
     
  13. alterian macrumors newbie

    Joined:
    Feb 22, 2013
    #13
    Same problem here. No wifi, 3g, sound, vibration and same issues with the power and connection to the PC. ive erased everything i could off cydia. idk what else to do
     
  14. stijepo15 macrumors newbie

    Joined:
    Feb 25, 2013
    #14
    My solution

    I had same prome, only diffrence was that sometimes my iphones battery worked, and sometimes don't, solution was that i put paper from left side of battery so the paper fix the battery and then everything was ok, i put paper on top of battery too, so it is now fixed, and its working
     
  15. Meeporonga macrumors newbie

    Joined:
    Apr 22, 2013
    #16
    i have had the same issue, but the best way and more homemade way to fix it was leaving it on DFU mode and not touching anything and not clicking anything in itunes when plugged and it charges just fine, but it lasts too little about 45 minutes, but in same cases its more then enogh to perform other tasks
     
  16. greenmagic macrumors newbie

    Joined:
    Feb 19, 2014
    #17
    I have the exact issue that DrunkenNinja posted in first post on my iPhone 4
    Exactly the same. I am wondering if a battery swap would do anything.
    It dies instantly when unplugged but also has long start up to activation screen if plugged into the wall, OR infinite boot loop if plugged into computer.
    I can get into recovery mode or DFU mode.
    But I don't want to do a restore and erase contents on phone which is what it sounded like DrunkenNinja may have done to solve his problem.
     

Share This Page