[iPhone 4] Pictures inside - Getting no service

Discussion in 'iPhone Tips, Help and Troubleshooting' started by reardear, Sep 21, 2013.

  1. reardear macrumors newbie

    Joined:
    Sep 11, 2013
    #1
    My phone was water damaged and had the rebooting problem, but a repair shop fixed that. The headphone jack, vibrate, and volume buttons also don't work, but that doesn't really matter. However, I'm also getting no service now. I went back to the shop and they tried replacing the antenna, but they didn't turn on 3G (which I need for service), and when I mentioned that they said it wouldn't work anyways... too lazy to check? -_-

    Other things I tried:
    • Seeing if carrier activated SIM (yes)
    • Resetting network settings

    So I went home and opened this up. I didn't see anything wrong, the blue inductor is there and I didn't see any corrosion.

    Please take a look. Here's the photo album:

    http://imgur.com/a/hEl8X
     
  2. reardear thread starter macrumors newbie

    Joined:
    Sep 11, 2013
    #2
    Any opinion or suggestion would be appreciated!
     
  3. yateseyd1991 macrumors regular

    Joined:
    Jun 23, 2011
    Location:
    UK
    #3
    Cleaning the motherboard with isopropyl alcohol and an anti-static brush may help, if not then its sounds like your signal issue is pretty terminal.


    :apple: iPhone 5 32GB White, iPad 3 16GB Black, rMBP 13" 256GB, iPod 5.5G 240GB, Shure SE425's :apple:
     
  4. zxoraz macrumors member

    Joined:
    Feb 16, 2011
    #4
    Same problem here.
    I entirely disassembled the phone and died everything out, haven't seen any signs of corrosion.
    Just curious,
    Do you see the IMEI when you type *#06# in the phone app?
    And does your phone work when not plugged to a charger?
     
  5. reardear thread starter macrumors newbie

    Joined:
    Sep 11, 2013
    #5
    Nope, I get an "Error performing request, No Network Service".

    It works when not plugged in.
     

Share This Page