iPhone 4 problem - won't turn on

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ineedhelp22, Aug 17, 2013.

  1. ineedhelp22 macrumors newbie

    Joined:
    Aug 17, 2013
    #1
    Hey today I was just using my iPhone and it randomly shut off and wouldn't turn back on. I noticed before it shut off that it was searching for service for some weird reason? Anyways, everytime i try to turn it on it boots up to the apple logo and immediately shuts off afterwards. I put it into restore mode with iTunes but I can't get it to restore - it just keeps giving me error 21. I've done all the error 21 fixes I could find on google to no avail. Does anybody have any knowledge about this that can help me fix it? It would be appreciated, thanks!
     
  2. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    Assume you're using the Recovery Mode as shown in http://support.apple.com/kb/ht1808?

    Error 21 usually occurs on a Windows computer, either some sort of security software or a bad hosts file. If you have a different computer available, try that. If you're stuck with this one, try creating a new user account & installing iTunes there, then run recovery mode and restore in that user account.
     
  3. ineedhelp22 thread starter macrumors newbie

    Joined:
    Aug 17, 2013
    #3
    Recovery mode isn't working like that exactly. It's going straight from the apple logo to the itunes logo with the usb plug. Also i've tried to fix the host files for a few hours already, messed around with tinyumbrella also. I can't figure it out, it just won't restore or turn on.

    I've also tried this on two computers i forgot to mention.
     

Share This Page