iPhone 4 problem

Discussion in 'Jailbreaks and iOS Hacks' started by Anghellic, May 20, 2012.

  1. Anghellic macrumors newbie

    Joined:
    May 20, 2012
    #1
    First of all, I'm new here, so sorry if I did wrong to open a new thread. Secondly, I'm relatively new to iOS too, and I'm experiencing some problems with my iPhone 4 on iOS 5.0.1

    I had my phone unlocked with SAM but iMessage wasn't working the other day, so I reset all the settings, which messed up my phone. Since I didn't have the original sim to activate iphone again (Swisscom is the original carrier, by the way), I used redsn0w to jailbreak it, and all the apps I had before came back. But the problem is, whenever I delete some app, after I reboot my phone, those deleted apps reappear. I have tried turning off automatic downloads of apps in Store settings, and nothing happened. I also tried deleting all the settings and data, waited for like 10 hours, but it gets stuck at Loading logo for like forever, so I just gave up on that. Any ideas on how to fix this problem? Or at least tell me how to reset my iPhone and delete everything on it and start from scratch?


    Thanks in advance :)
     
  2. chenks macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #2
    first of all, why are you still using iOS 5.0.1?
    the current release is iSO 5.1.1.
     

Share This Page