Resolved iPhone 4 Restore iOS5.0.1 Error 21 & 1601

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sunraizes, Jan 14, 2012.

  1. sunraizes, Jan 14, 2012
    Last edited: Jan 15, 2012

    sunraizes macrumors newbie

    Joined:
    Jan 14, 2012
    #1
    Hi!

    My iPhone 4 is on 4.3.3 Jailbroken.
    (Windows Vista 32-bit, latest iTunes)

    I tried to restore to latest ios 5.0.1. Then I got the following error:

    1) When restore normally, got error 21.
    2) When restore in DFU mode, got error 1601, 1602.

    I tried to reinstall iTunes, changing usb port, and used iREB r5 to no avail.

    What else should I try?

    Anybody can help me out, will really appreciate it! ;)

    Updates:

    I solved it using latest redsn0w, go to extras > fix recovery.
    From there it will load some commands in iPhone, and voila welcome activation screen, with ios 5.0.1.

    ;)
     
  2. pizzutelli macrumors newbie

    Joined:
    Feb 4, 2012
    #2
    thanks a lot

    I was really concerned, I tried update to 5.0.1 and it crashed leaving my iphone dead. Really a bad night.
    Thank your advice I got back to a working 4.3.3 then updated to 5.0.1 through a pc instead of a macbook (!!!) and it worked good.
    A kiss on the top of your smart head.
     

Share This Page